Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 702
  • Last Modified:

apahce virtual hosting issues

hi i am getting errors while i am configuring for my new virtual directory which i am doing exactly the same thing as i did for other virtual directories. when i added is.perfectsolution.com.au, it wont let me add new virtual directory.

[error] (EAI 2)Name or service not known: Could not resolve host name *.80 -- ignoring!
httpd: apr_sockaddr_info_get() failed for linux_pc
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName

can anyone help me on this ?

<VirtualHost *:80>
    ServerAdmin emeraldpiggy@gmail.com
    DocumentRoot /usr/local/Zend/apache2/htdocs/medroster/
    ServerName medroster.perfectsolution.com.au
    ServerAlias medroster.perfectsolution.com.au
    ErrorLog logs/medroster-error_log
    CustomLog logs/medroster-access_log common
</VirtualHost>
 
<VirtualHost *:80>
    ServerAdmin emeraldpiggy@gmail.com
    DocumentRoot /usr/local/Zend/apache2/htdocs/timesbusiness/
    ServerName tbp.perfectsolution.com.au
    ServerAlias tbp.perfectsolution.com.au
    ErrorLog logs/tbp-error_log
    CustomLog logs/tbp-access_log common
</VirtualHost>
 
<VirtualHost *.80>
    ServerAdmin emeraldpiggy@gmail.com
    DocumentRoot /usr/local/Zend/apache2/htdocs/instantstorage/
    ServerName is.perfectsolution.com.au
    ServerAlias is.perfectsolution.com.au
    ErrorLog logs/is-error_log
    CustomLog logs/is-access_log common
</VirtualHost>
 
hosts file 
 
60.242.178.134 www.perfectsolution.com.au perfectsolution
60.242.178.134 medroster.perfectsolution.com.au medroster
127.0.0.1 localhost.is.perfectsolution.com.au localhost
60.242.178.134 tbp.perfectsolution.com.au tbp
60.242.178.134 is.perfectsolution.com.au is

Open in new window

0
emeraldpiggy
Asked:
emeraldpiggy
  • 5
  • 4
1 Solution
 
fosiul01Commented:
spelling mistake of this line
<VirtualHost *.80>
    ServerAdmin emeraldpiggy@gmail.com
    DocumentRoot /usr/local/Zend/apache2/htdocs/instantstorage/
    ServerName is.perfectsolution.com.au
    ServerAlias is.perfectsolution.com.au
    ErrorLog logs/is-error_log
    CustomLog logs/is-access_log common
</VirtualHost>


it should be

<VirtualHost *:80>
    ServerAdmin emeraldpiggy@gmail.com
    DocumentRoot /usr/local/Zend/apache2/htdocs/instantstorage/
    ServerName is.perfectsolution.com.au
    ServerAlias is.perfectsolution.com.au
    ErrorLog logs/is-error_log
    CustomLog logs/is-access_log common
</VirtualHost>
0
 
emeraldpiggyAuthor Commented:
hi fosiul01
?
which line?
0
 
emeraldpiggyAuthor Commented:
my mistake
it has new errors now

httpd: apr_sockaddr_info_get() failed for linux_pc
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
0
Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

 
fosiul01Commented:
Ok  this one is not actually errro

httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName


does it say, Ok ??

does it failed to restart ?
0
 
emeraldpiggyAuthor Commented:
hi fosiul01
ur right, it lets me go thru with the restarting process
but why it happens since i think i ve got everything right in both hosts file and vhosting file?
thanks again for your help
0
 
fosiul01Commented:
its because of your /etc/hosts file setting

currently you have

127.0.0.1  localhost.localdomain  localhost

you need to insert your host name of the pc and the IP of the pc

192.168.1.2   webserver.yourdomain.com



0
 
emeraldpiggyAuthor Commented:
hi i did for all my virtualhosting
but it still displaying the same msg

127.0.0.1 localhost.localadmin localhost
192.168.0.3 www.perfectsolution.com.au perfectsolution
60.242.178.134 www.perfectsolution.com.au perfectsolution
60.242.178.134 medroster.perfectsolution.com.au medroster
192.168.0.3 medroster.perfectsolution.com.au medroster
60.242.178.134 tbp.perfectsolution.com.au tbp
192.168.0.3 tbp.perfectsolution.com.au tbp
60.242.178.134 is.perfectsolution.com.au is
192.168.0.3 is.perfectsolution.com.au is
60.242.178.134 wbn.perfectsolution.com.au wbn
192.168.0.3 wbn.perfectsolution.com.au wbn
60.242.178.134 afd.perfectsolution.com.au afd
192.168.0.3 afd.perfectsolution.com.au afd
60.242.178.134 bidlane.perfectsolution.com.au bidlane
192.168.0.3 bidlane.perfectsolution.com.au bidlane

plz advice
0
 
fosiul01Commented:
No, its not this way

whats the host name of your Pc ?? and whats the domain of your network  and Ip of your pc ??

just keep only 1 line , Delete all


127.0.0.1 pchostname.domain.local  

Delete  localhost.localdomain localhost

Note : just keep this line
127.0.0.1 pchostname.domain.local  

and Delete everything

but change  pchostname.domain.local   to according to your setting
0
 
emeraldpiggyAuthor Commented:
thanks but i couldnt fix it as the way u ve told me.
i fixed by using following command.
echo HOST.DOMAIN.com > /etc/hostname
/bin/hostname -F /etc/hostname

However, i really appreciate your effort  
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now