Cannot access DFS Replication performance counters

Posted on 2009-04-26
Last Modified: 2013-07-25

Running Windows Server 2003 Enterprise edition on 2 servers with a single DFS Replication group set up.

In trying to run a DFS Diagnostics Report for the replication group, I am presented with the following report results:

Cannot access DFS Replication performance counters.
Affected replicated folders: All replicated folders on this server.
Description: The DFS Replication service is unable to access the performance counter DFS Replicated Folders(Inetpub-{C6167E0E-EB45-4459-A081-156BD93F3F7E})\File Installs Succeeded on SV3069. Performance data is unavailable. Error ID: 0x800007d5.
Last occurred: Sunday, April 26, 2009 at 1:38:34 PM (GMT-5:00)
Suggested action: For information about troubleshooting this problem, see .

I have run WMIDiagnostics to resolve several permissions issues, but nothing I have done has changed the results of the DFS Report.

I've followed to repair the WMI to no avail.

Please help.
Question by:brock_hensley
    LVL 6

    Accepted Solution


    Try the following

    1. Enable the Remote Registry service. The default configuration for the Remote Registry service is startup type Automatic and set to log on as NT AUTHORITY\LocalService.

    On the machine that has the problem try running the following to confirm if the counters can be accessed:
    wmic path Win32_PerfFormattedData_Dfsr_DFSReplicatedFolders

    If you get an error:
    Code = 0x80041010
    Description = Invalid class
    Facility = WMI

    Stop DFSR service:
    net stop dfsr

    then run the following command to refresh the performance counter classes:
    wmiadap /f

    Start DFSR service:
    net start dfsr

    Run the above command again to confirm that the class is registered:
    wmic path Win32_PerfFormattedData_Dfsr_DFSReplicatedFolders

    Rerun health report to confirm that the error is gone.

    LVL 1

    Author Closing Comment

    Thank you! I had looked at the Remote Registry Service but didn't think it was required to be running. FIgures.

    Expert Comment

    Hello. I am having the same issue, however, after performing the steps in the solution, I still get the same error: 0x80041010

    Is there something else (or somewhere else) I need to look at?


    Featured Post

    Want to promote your upcoming event?

    Is your company attending an event or exhibiting at a trade show soon? Are you speaking at a conference? Spread the word by using a promotional banner in your email signature. This will ensure your organization’s most important contacts are in the know.

    Join & Write a Comment

    The environment that this is running in is SCCM 2007 R2 running on a Windows 2008 R2 server. The PXE Distribution point is running on its own Windows 2008 R2 box. This is what Event viewer showed after trying to start the WDS service:  An erro…
    A quick step-by-step overview of installing and configuring Carbonite Server Backup.
    Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…
    This video discusses moving either the default database or any database to a new volume.

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now