?
Solved

Error message when adding on FCKeditor. "The server didnt send back a proper XML response. Please contact your system administrator."

Posted on 2009-04-26
2
Medium Priority
?
1,398 Views
Last Modified: 2013-11-19
Hi
I'm using FCKeditor 2.6.4  in my website designed with ASP.NET 2005 and c#.
When I try to add an image to the html, using Image button a page will show up(pic 1).
The error occures when I click on "Browse Server". the error  (pic 2) is:

"The server didnt send back a proper XML response. Please contact your system administrator."
"XML request error: OK (200) "

I found hundreds of questions on the internet but no one could solve my problem.
Please tell me what to do.
1.JPG
2.JPG
0
Comment
Question by:Elham_Seif
2 Comments
 
LVL 5

Accepted Solution

by:
blacksix earned 1500 total points
ID: 24243480
A few questions / possible ideas

1) do you know what your memory limit is? Could be possible the server is running out of memory before the form is finishing.

2) does this work better in one browser than another? Any difference at all?

3) How large is the image you are uploading? Try and test with a tiny image just to see if that makes a difference.

4) does the error come as soon as you click browse? Or does it come after you choose the file to upload and click OK?

4) It looks like the editor is calling up a php script to handle the request. Is php not installed on the server? Looks like FCK editor either isn't installed correctly or requires php to be installed? Did you follow the best practices here for installation of fckeditor?:
http://docs.fckeditor.net/FCKeditor_2.x/Developers_Guide/Integration/ASP.NET
0
 

Author Closing Comment

by:Elham_Seif
ID: 31574799
Thanks for your hint about PHP script. PHP wasn't installed on my computer. But Instead of installing PHP I just changed a parameter
_FileBrowserLanguage and _QuickUploadLanguage in fckconfig.js from PHP to ASPX. This way I use connector.aspx instead of connector.PHP.
Then there was another error about activing connector.aspx which was easily solved by returning true in it's CheckAuthentication method in config.ascx.
after that I faced another error with error code 500. I solve it by managing UserFilesPath parameter in config.ascx file. I set it to
  UserFilesPath = Request.ApplicationPath + "/"; // "/userfiles/";
and I add image directory to the root of my application.
Anyway, thanks for your help.
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When the s#!t hits the fan, you don’t have time to look up who’s on call, draft emails, call collaborators, or send text messages. An instant chat window is definitely the way to go, especially one like HipChat. HipChat is a true business app. An…
Ready to get certified? Check out some courses that help you prepare for third-party exams.
Viewers will get an overview of the benefits and risks of using Bitcoin to accept payments. What Bitcoin is: Legality: Risks: Benefits: Which businesses are best suited?: Other things you should know: How to get started:
This tutorial will teach you the core code needed to finalize the addition of a watermark to your image. The viewer will use a small PHP class to learn and create a watermark.
Suggested Courses
Course of the Month12 days, 16 hours left to enroll

578 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question