Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 229
  • Last Modified:

zone file doesn't have a NS record ?

Folks

Probably missing something obvious but I'm having a problem with a zone file (attached bellow) not loading on my BIND9 server with error:

27-Apr-2009 10:22:12.120 general: error: zone dinico.ch/IN: has no NS records

I might be not fully awaken this morning but I can figure it out. Any help most welcome.

Regards

alex
$TTL 14400
@     IN      SOA     ns.dinico.ch.    domainadmin.dinico.ch. (
			2009042801	; Serial
			3600		; Refresh
			360		; Retry
			1209600	; Expire
			3600 )	; Min TTL
                       
ns.dinico.ch.       IN A 88.191.98.49
ns1.dinico.ch.      IN A 88.191.98.49
test.dinico.ch.	    IN A 88.191.48.160
dinico.ch.	    IN A 88.191.98.49
www.dinico.ch.	    IN A 88.191.98.49
ftp.dinico.ch.	    IN A 88.191.98.49
 
 
	IN      NS   	ns.dinico.ch.
	IN   	NS      ns1.dinico.ch.
	IN	NS	ns2.mydyndns.org.
	IN	NS	ns3.mydyndns.org.
	IN	NS	ns4.mydyndns.org.
	IN	NS	ns5.mydyndns.org.
 
	IN	MX	10	aspmx.l.google.com.
	IN	MX	20	alt1.aspmx.l.google.com.
	IN	MX	30	alt2.aspmx.l.google.com.

Open in new window

0
Alexandre Takacs
Asked:
Alexandre Takacs
1 Solution
 
Chris DentPowerShell DeveloperCommented:

If I remember correctly (and I have nothing to test this against) but leaving the resource name blank uses the last value for the resource (not the origin).

Move the A records beneath the MX records and the problem "should" go away.

Chris
0
 
omarfaridCommented:
move the NS records to be before the A ones since the domain name changes
0
 
Alexandre TakacsCTOAuthor Commented:
Yes - that was my mistake - good (and quick) catch !!
0

Featured Post

Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now