Exchange 2003 random event ID 2012 & 2013 SMTP could not connect to any DNS server

on 4/24 our single exchange server started to randomly pop up warnings and errors for event ID 2012 and 2013

SMTP could not connect to any DNS server. Either none are configured, or all are down.

SMTP could not connect to the DNS server 'DNS SERVER IP'. The protocol used was 'UDP'. It may be down or inaccessible.

Everything seems to be running fine.  Inbound and outbound email seems to be functioning.  The queues have a relatively low amount of messages.

I ran NETDIAG and everything shows success.  I ran DNSDIAG for our mail host name and that resolved and passed successfully.  I checked the NICs statistics and there are not TCPIP errors or anything like that.  I've run DCDIAG on the domain controller(also the DNS server).  My SMTP Virtual server does not have any DNS server configured.  Only the pri and sec in TCP IP config and I have tested full connectivity to both.  

I am stumped.  I am still randomly seeing these event IDs.
NBFAsked:
Who is Participating?
 
NBFConnect With a Mentor Author Commented:
Problem resolved on its own.
0
 
Sourabh-ExcahngeCommented:
1. In Exchange System Manager go to Servers/[your server]/Protocols/SMTP
2. right click on the Default SMTP Virtual Server and select Properties
3. Click on the Delivery tab
4. Click on Advanced button
5. Click on the Configure button next to "Configure external DNS Servers"
6. If there are External servers listed in this dialog box remove them.
7. restart the Default SMTP Virtual Server
0
 
Sourabh-ExcahngeCommented:
there is another article which might help you
http://support.microsoft.com//kb/909143 
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
NBFAuthor Commented:
Our default virtual SMTP server does not have any external DNS servers configured.
0
 
Sourabh-ExcahngeCommented:
and how abt the article i gave you if that dosent resolve the issue please Uninstalled and then upgraded to the latest build of Symantec Mail Security.
0
 
Sourabh-ExcahngeCommented:
another thing which you can check is any obsolete domain A records for the domain controller that no
longer exist in the domain.
0
 
NBFAuthor Commented:
We are running SMS 5.0.8.376.  I guess I can run a liveupdate after hours to see if that helps.  I can't see why that would be a cause all of a sudden.

There are no obsolete domain A records for domain controllers in the domain.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.