• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 290
  • Last Modified:

Cisco VPN Clients Can't Connect

We are using a cisco ASA 5505 security device.  Lately, there were some changes to the config file and now the vpn clients can't connect.  Here is the running config.  If anyone can figure out where my trouble is, I would appreciate it.  thanks.

ASA Version 7.2(2)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password wZfn4TUNceSqfkgV encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address pppoe setroute
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd wZfn4TUNceSqfkgV encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name default.domain.invalid
object-group network inside
 network-object 192.168.1.0 255.255.255.0
object-group network vpnclients
 network-object 192.168.2.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip any 192.168.2.0 255.255.255.
0
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 19
2.168.2.0 255.255.255.0
access-list smtp extended permit tcp any host 74.42.8.17 eq smtp
access-list smtp extended permit tcp any host 74.42.8.17 eq www
access-list smtp extended permit tcp any host 74.42.8.17 eq https
access-list smtp extended permit udp any host 74.42.8.17 eq 29603
access-list smtp extended permit tcp any host 74.42.8.17 eq 29603
access-list split-tunnel extended permit ip 192.168.1.0 255.255.255.0 192.168.2.
0 255.255.255.0
access-list test webtype permit tcp 192.168.1.0 255.255.255.0 log default
pager lines 24
logging enable
logging buffered notifications
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool phccabington 192.168.2.0-192.168.2.253 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface smtp 192.168.1.9 smtp netmask 255.255.255.
255
static (inside,outside) tcp interface https 192.168.1.9 https netmask 255.255.25
5.255
static (inside,outside) tcp interface www 192.168.1.9 www netmask 255.255.255.25
5
static (inside,outside) tcp interface 29603 192.168.1.45 29603 netmask 255.255.2
55.255
access-group smtp in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
aaa-server PhccVpnUsers protocol radius
aaa-server PhccVpnUsers host 192.168.1.4
 timeout 5
 key E2:8Fbgyhbs
aaa-server AD_Auth protocol nt
aaa-server AD_Auth host 192.168.1.4
 nt-auth-domain-controller 192.168.1.4
group-policy phccabington internal
group-policy phccabington attributes
 wins-server value 192.168.1.4 192.168.1.6
 dns-server value 192.168.1.4 192.168.1.6
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value split-tunnel
 default-domain value phcc.int
group-policy phccvpn internal
group-policy phccvpn attributes
 wins-server value 192.168.1.4 192.168.1.6
 dns-server value 192.168.1.4 192.168.1.6
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value split-tunnel
 default-domain value phcc.int
username tgattorna password A5oXdNd3.3sEhzYt encrypted privilege 0
username admin password Qyt908tEpeoOu0oA encrypted
username dsteier password IdYn1VlBhGzwvlxo encrypted privilege 15
username dsteier attributes
 vpn-group-policy phccabington
username lstech password ucUIkhrdvF2Z0BY9 encrypted privilege 15
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
aaa authentication telnet console LOCAL
http server enable
http 203.167.x.x 255.255.255.255 outside
http 192.168.1.0 255.255.255.0 inside
http 74.212.x.x 255.255.255.0 outside
snmp-server host inside 192.168.1.7 community public udp-port 161
no snmp-server location
no snmp-server contact
snmp-server community public
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 60 set pfs
crypto dynamic-map outside_dyn_map 60 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 80 set pfs
crypto dynamic-map outside_dyn_map 80 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 100 set pfs
crypto dynamic-map outside_dyn_map 100 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 120 set pfs
crypto dynamic-map outside_dyn_map 120 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 140 set pfs
crypto dynamic-map outside_dyn_map 140 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
tunnel-group phccvpn type ipsec-ra
tunnel-group phccvpn general-attributes
 address-pool phccabington
 authentication-server-group PhccVpnUsers
 default-group-policy phccvpn
tunnel-group phccvpn ipsec-attributes
 pre-shared-key *
telnet 192.168.x.x 255.255.255.0 inside
telnet timeout 5
ssh 74.212.x.x 255.255.255.0 outside
ssh timeout 5
console timeout 0
vpdn group frontier request dialout pppoe
vpdn group frontier localname phcc
vpdn group frontier ppp authentication pap
vpdn username phcc password *********
dhcpd dns 192.168.1.x 192.168.1.x
dhcpd wins 192.168.1.x 192.168.1.x
dhcpd domain phcc.int
dhcpd auto_config outside
dhcpd update dns both
!
dhcpd address 192.168.1.30-192.168.x.x inside
dhcpd enable inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
tftp-server inside 192.168.1.7 c:\tftp-root
prompt hostname context
Cryptochecksum:25769b0fe0a3569a1246169219470500
: end
ciscoasa#
0
phcc75
Asked:
phcc75
  • 4
  • 3
1 Solution
 
MikeKaneCommented:
Can you provide a copy of the previous config?    If not, can you provide a copy if the logs from the client or from the firewall during a connection attempt.

What is the error you are getting?  Any messages?  

0
 
phcc75Author Commented:
The only thing that I have to work with is the following message the vpn client gives me:

"Reason 412: Remote Peer is no longer responding"
0
 
MikeKaneCommented:
Did the outside interface IP change?    New ISP perhaps?     Its kind of hard to troubleshoot without knowing what the issue is (lacking a log file or exact error messages)    
0
Rewarding opportunities for women in IT

Across the nation, technology jobs are vacant because there aren’t enough qualified professionals to fill them. With a degree from WGU, you can get the credentials it takes to become an in-demand IT professional. Plus, WGU’s IT programs include industry certifications.

 
phcc75Author Commented:
The outside IP is static and there have been no changes to the ISP.  Sorry I don't have more info.
0
 
MikeKaneCommented:
"Remote Peer is no longer responding" means the VPN client is not getting a reply from the Firewall.   Are the communications from the client even getting to the firewall?    If they are, then you need to look at the Phase 1 policy.     We need to have a look at the error logs to pinpoint which setting is the cause of the error.

You can use this to get detailed info:
debug crypto isakmp
debug crypto ipsec

Here is the cisco link about the debug:
http://www.cisco.com/en/US/tech/tk583/tk372/technologies_tech_note09186a00800949c5.shtml#pix_dbgs
0
 
phcc75Author Commented:
I found the issue.  There vpn client software had issues with this mac.
0
 
phcc75Author Commented:
There was a problem with the vpn client software and the mac.
0

Featured Post

A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now