?
Solved

Remote VPN config

Posted on 2009-04-27
2
Medium Priority
?
423 Views
Last Modified: 2012-05-06
i have a cisco router 1841 and i need to configure VPN on it. i want to connect to it through a cisco remote vpn client from anywhere.

Could you provide me with sample configs????
0
Comment
Question by:outlaw17
2 Comments
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 2000 total points
ID: 24244188
Here is an example:

username <vpnuser1> password <password>
username <vpnuser2> password <password>
username <vpnuser3> password <password>
username <vpnuser4> password <password>

aaa authentication login vpn-authentication local
aaa authorization network vpn-authorization local

ip local pool vpn-pool 10.255.255.10 10.255.255.250

crypto isakmp policy 1
 encr 3des
 authentication pre-share
 group 2

crypto isakmp client configuration group <groupname>
 key <presharedkey>
 dns x.x.x.x y.y.y.y    <--DNS servers
 pool vpn-pool
 acl vpn-split-tunnel
 netmask 255.255.255.0
!
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
!
crypto dynamic-map dynmap 1
 set transform-set ESP-3DES-SHA
!
!
crypto map vpn client authentication list vpn-authentication
crypto map vpn isakmp authorization list vpn-authorization
crypto map vpn client configuration address respond
crypto map vpn 65535 ipsec-isakmp dynamic dynmap

int s0/0/0
crypto map vpn

ip access-list extended vpn-split-tunnel
 permit ip 10.0.0.0 0.0.0.255 10.255.255.0 0.0.0.255


access-list 102 deny 10.0.0.0 0.0.0.255 10.10.10.0 0.0.0.255
access-list 102 permit 10.0.0.0 0.0.0.255 any

ip nat inside source list 102 interface Serial0/0/0 overload
0
 

Author Comment

by:outlaw17
ID: 24244227
thank you so much.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question