?
Solved

Why can't I scan over the network from Brother MFC-8840DN?

Posted on 2009-04-27
8
Medium Priority
?
1,735 Views
Last Modified: 2013-12-27
I have a Brother MFC-8840DN all-in-one connected to a small LAN.  Several computers are setup to be recognized by the printer, i.e., they appear on the printer's list of "scan to" PCs.  There are 2 ways to do network scanning with this setup.  One is to select the software scan button on the computer, and the other is to press the scan button on the printer and tell it which PC to scan to.  Basically this just tells the scanner what settings to use, i.e. color or B&W, file type, and where to save the resulting file.  The problem is that since we recently switched to Small Business Server 2007, the computers that are running Windows XP cannot use the later method, while computers that are running Windows 2000 can.  Both types of computer can scan using method one.  When we used Windows 2000 Server all computers could use either method.  I looks to me like there is some security setting that is causing the XP machines to reject the printer's request to connect to the PC.  Everything looks nominal but when you press the "scan" button on the printer and the "connecting to PC" message appears, nothing happens until it just disappears after about a minute.

Any ideas what needs to be changed?
0
Comment
Question by:mvpharm
8 Comments
 
LVL 5

Expert Comment

by:dcsdave
ID: 24244271
Can you re-run the scanner setup from CD on one of the XP boxes that it is now on the SBS network and see if scanning works after that?
0
 
LVL 12

Expert Comment

by:nealerocks
ID: 24244316
The SBS server had probably implemented a group policy relating to the windows firewall. Check the windows firewall setting on one of the Windows XP computers to see if file and printer sharing is allowed.
You may need to edit the group policy in Active Directory on the SBS server to open the firewall ports that you need.
Windows 2000 doesn't have the Windows firewall so this might explain it.
0
 
LVL 9

Expert Comment

by:tomcahill
ID: 24244436
SBS 2008 will modify the Firewall, but you can still add exceptions.  There must be some Brother software sitting on the machines that receives the scan signal.  You should be able to add that program to the exceptions.  Alternatively add UDP port 54925 to the exceptions to allow for the scanning to work.

check out this link:
http://welcome.solutions.brother.com/BSC/public/us/ca/en/faq/faq/000000/000100/000085/faq000185_002.html?reg=us&c=ca&lang=en&prod=mfc8840dn_all&Cat=8

There is a patch as well that is supposed to fix this problem.

If you have a lot of machines to work on for this then I suggest you use the UDP method and set that exception using Group Policy.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
LVL 9

Expert Comment

by:tomcahill
ID: 24244450
sorry, you also need TCP 137
0
 

Author Comment

by:mvpharm
ID: 24245534
Windows firewall is enabled, but there is no file and print sharing setting there.  Under network connections however, file and print sharing is enabled.  

Can you give me a little lesson on editing the group policy on the SBS.  I have not found any setting that looks promising.

Thanks
0
 
LVL 9

Accepted Solution

by:
tomcahill earned 2000 total points
ID: 24245623
Click Start,
Go to Administrative Tools.
Click Group Policy Management.
Expand MyBusiness
Expand Computers
Expand SBSComputers
Right click Windows SBS Client Policy and click Edit
Group Policy Management Editor will appear
Under Computer Configuration, Expand Administrative Templates
Expand Network
Expand Network Connections
Expand Windows Firewall
Double Click Windows Firewall:Define Inbound port exceptions
Select Enabled
click Show
Click Add
Paste in the following lines, one at a time:
137:TCP:"*":enabled:Brother Printer  1
137:UDP:"*":enabled:Brother Printer  2
54925 :TCP:"*":enabled:Brother Printer  3
54925 :UDP:"*":enabled:Brother Printer  4

Then click Apply and Ok.
Close GPME and GPM.
It will take a bit of time for the policy to spread to the clients.  You can force it by running gpupdate/force on each one though.



0
 
LVL 9

Expert Comment

by:tomcahill
ID: 24245646
I put both TCP and UDP for each because the Brother documentation was a little weird.
0
 

Author Closing Comment

by:mvpharm
ID: 31575092
Thank you, you get the points.  I actually only needed to add the UDP 54925 to the local firewall exceptions list to get the scanning to work.  I only have a few machines so that was convenient.  Thank you for the more general group policy answer.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains the fundamentals of industrial networking which ultimately is the backbone network which is providing communications for process devices like robots and other not so interesting stuff.
Tech spooks aren't just for those who are tech savvy, it also happens to those of us running a business. Check out the top tech spooks for business owners.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question