• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 652
  • Last Modified:

Installing a 1 TB internal Hard Drive on OS Windows 2000 Professional

I trying to add another Hard Drive to my HP Compaq dc5100 computer. When I install the 1 TB hard drive Windows only recognizes 128GB.  How do I get the entire 1 TB drive to be fully recognized?
0
wmccann04
Asked:
wmccann04
  • 2
  • 2
  • 2
2 Solutions
 
oBdACommented:
Assuming you already have SP2 or later installed, you still need a registry change; check this article for details:
48-Bit LBA Support for ATAPI Disk Drives in Windows 2000
http://support.microsoft.com/kb/305098
0
 
wmccann04Author Commented:
I have windows 2000 SP4. I added the value to my registry, did a restart and it still shows 127GB for the 1 TB drive.
0
 
oBdACommented:
Is the full size of the disk recognized in the BIOS? If not, you'll have to look for a BIOS upgrade for your machine, your current one probably doesn't support 48bit LBA; note the other prerequisite:
"* A computer with a 48-bit LBA-compatible Basic Input/Output System (BIOS) installed."
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
Gary CaseRetiredCommented:
With both SP4 and the EnableBigLBA registry key, you've definitely got 48-bit logical block addressing added to your 2000 installation.

This would normally mean the BIOS only supports 28-bit LBA's ... but this system is relatively new AND it shipped with up to 160GB drives (which means it clearly has 48-bit LBA capability) ...

... so I suspect you simply need to delete the 128GB partition you created when you first initialized the drive and repartition the drive.

Go to Disk Management and see what it shows for the drive -- I suspect you'll find a 128GB partition and a bunch of unallocated space :-)     Just delete the 128GB partition;  then repartition the drive to get the full 1TB of capacity.
0
 
Gary CaseRetiredCommented:
... I assume you know this, but just in case:   To get to Disk Management, just right-click on My Computer; select Manage; and then click on Disk Management in the list on the left side (under Storage).   You should then see your disk on the right side -- just right-click on the 128GB partition and select Delete;  then right-click in the unallocated space for the drive and create a new partition that uses the entire drive.
0
 
wmccann04Author Commented:
That did it. Thank you both for your help with my problem.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

  • 2
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now