• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2029
  • Last Modified:

How do I mount a Novell volume from Linux?

I'm running Ubuntu 9.04 on my laptop and wish to connect to a Novell server but when I try:
ncpmount -A 10.198.0.3 -U novellusername /media/data01/ -V data01
I get "ncpmount: Unknown user (0x89FC) in find_conn_spec"
What am I doing wrong?

Jason
0
jasonzx
Asked:
jasonzx
1 Solution
 
ewest02Commented:
This may or may not help you.. I found on the 'net a reference to setting the -U value to "lpart"  . You will be prompted then for a username/password.  It was claimed to resolve the find_conn_spec problem for the poster. This person used the ncpmount command with:

     ncpmount -S asc_2001 -f 0664 -d 0775 -U lpart /mnt/asc_2001

...replace the -S value and the mount point as appropriate...

ref: http://www.computing.net/answers/netware/netware-and-linux-ncpmount/4428.html

  --Eric
0
 
ewest02Commented:
Possibly worth the look???

Direct from Novell:
   http://www.novell.com/coolsolutions/trench/16445.html

Also found on this site:
    http://www.experts-exchange.com/Networking/Linux_Networking/Q_20995471.html

  --Eric
0
 
alextoftCommented:
It's not a Novell server, it's a Netware server. Netware is a product of Novell.

If it's a recent version of Netware it will come with Native File Access. This means it supports CIFS, AFP and NFS making things a lot easier.
0
 
jasonzxAuthor Commented:
ewest02:
 Tried: ncpmount -S server -f 0664 -d 0775 -U user /media/data01
 and got: ncpmount: Server not found (0x8847) when trying to find server
 Tried by server name and IP and results were the same

alextoft:
 Which solution has better support under linux? CIFS, AFP or NFS, are there any clear advantages to using one rather than another?
0
 
ZENandEmailguyCommented:
try ncpmount -S ip_address_of_server -A dns_name_of_server -U cn=your-user-name.ou=your-context.o=whatever is necessary /media/<directory to represent server name>

Try (if you have the credential/password) to use your admin account first.  If that works, then try your own account.

IMO, CIFS is a great way to attach to a NetWare server but doing so assumes that you have the ability to set a Simple Password on your account and that your context in eDirectory is found in the sys:/etc/cifsctxs.cfg file and that the CIFS.NLM and support NLMs are running (do a CIFSSTRT.NCF if they are not).

Hope that helps.

Scott
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now