• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 533
  • Last Modified:

Why is the data cutting off in crystal reports level and not in database?

I've a report based off a stored procedure in Oracle 10g. The query works fine and there is a field of service type with datatype as varchar with 80 bytes. I've Business View in between Crystal reports & database. When i run the report from Crystal, the original value of the "Service Type" field gets cut off. For eg., it has "Product Line" value for "Service Type" field in database but when i run the report i get only "Product Li". Also, i noticed the datatype in Crystal is string with length as 10. When i browse the data from crystal i can not see the full value of the fields. It's cutting off there too. Please help.
0
baralp
Asked:
baralp
  • 3
  • 3
2 Solutions
 
mlmccCommented:
Try to verify the database
Open the report
Click DATABASE --> VERIFY DATABASE

What database connectiion method?

mlmcc
0
 
baralpAuthor Commented:
I tried that. But it doesn't work. I'm using Business View in between Crystal Reports & Oracle 10g. And the database connection is ODBC.
0
 
mlmccCommented:
Check tha t the Business Vies is changing the data type.

mlmcc
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
baralpAuthor Commented:
In the Data Foundation of Business View, the same "Service Type" field is of datatype string and has length 22. When i browse the data for that field in Business View, i can see the entire name. So in business view looks like it's fine. It's causing problem when i come back to crystal. Also, i didn't get why the data type is of length 10 only in crystal. I think that's the reason its cutting off. Please help.
0
 
mlmccCommented:
If you build a new report do you get the same result?

Any other string fields with this problem?

mlmcc
0
 
dcurry22Commented:
I may be stating the obvious but here goes: Two things came to mind.
1) Is your field (box) on your crystal report wide enough to display all the data?
2)Your data is coming in as a varchar(80) and ends up in CR as a string.  So , check that field manipulation and see that you did the convert   Convert.ToString(field).Trim()  or whatever properly.  
Just trying to help. Good luck.
0
 
baralpAuthor Commented:
mlmcc: Yes i build the new report and still got the same problem.
dcurry22: Thanks for ur help but that didn't work.
But what i figured out is, I had the "Service Type" field from different table in the stored procedure. Later, I changed that field to report off different table in stored proc. And, i forgot to update the table in the Business View level at Data Foundation. When i update the "Set Table Location" in Data Foundation the length of the field changed to 160 and same effect in crystal so finally i was able to see the entire value for that field.
Anyways, thanks guys.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now