[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3687
  • Last Modified:

JSTL exception in Weblogic 10

Hi,
I am developing a web application to run on Java5, and Weblogic Application Server 10.x.
I am also using struts to develop the application. Ihave the jstl.jar and standard.jar in WEB-INF\lib directory. Also have c.tld (that I extracted from jstl.jar). I have done the mapping of the URI in the web.xml file and referring to the same URI in my JSP. But when I am trying to render the JSP, it is not getting compiled and throws exception as follows:

Compilation of JSP File '/resources/jsp/noProjectsAssigned.jsp' failed:
--------------------------------------------------------------------------------
 
noProjectsAssigned.jsp:1:1: The validator class: "org.apache.taglibs.standard.tlv.JstlCoreTLV" has failed with the following exception: "java.lang.ClassCastException: weblogic.xml.jaxp.RegistrySAXParserFactory".
<%@ page language="java" contentType="text/html; charset=ISO-8859-1" pageEncoding="ISO-8859-1"%>
^----------------------------------------------------------------------------------------------^

I checked the version of JSTL in the manifest.mf file in the JAR and it is as follows:

Manifest-Version: 1.0
Ant-Version: Apache Ant 1.6.5
Created-By: 1.5.0_06-b03 (Sun Microsystems Inc.)
Extension-Name: javax.servlet.jsp.jstl
Specification-Title: JavaServer Pages(TM) Standard Tag Library
Specification-Version: 1.2
Specification-Vendor: Sun Microsystems, Inc.
Implementation-Version: 1.2
Implementation-Vendor: Sun Microsystems, Inc.
Implementation-Vendor-Id: org.apache
Implementation-Title: Sun Java System Application Server


AND in standard.jar

Manifest-Version: 1.0
Ant-Version: Apache Ant 1.6.1
Created-By: 1.4.2-38 ("Apple Computer, Inc.")
Specification-Title: JavaServer Pages Standard Tag Library (JSTL)
Specification-Version: 1.1
Implementation-Title: jakarta-taglibs 'standard': an implementation of
  JSTL
Implementation-Version: 1.1.2
Implementation-Vendor: Apache Software Foundation
Implementation-Vendor-Id: org.apache
Extension-Name: org.apache.taglibs.standard


I am doing something wrong somewhere!
Any help is really appreciated.

Please let me know you need more information!!

--Nitin
0
nitin22
Asked:
nitin22
  • 5
  • 3
2 Solutions
 
rrzCommented:
I would delete the two jars you have now and start over. You can download the binary  from  
http://jakarta.apache.org/site/downloads/downloads_taglibs-standard.cgi 

>Also have c.tld (that I extracted from jstl.jar). I have done the mapping of the URI in the web.xml file  
Don't  either of those things. Delete them.  
> referring to the same URI in my JSP.    
The line in your JSP should be like  
<%@taglib uri="http://java.sun.com/jsp/jstl/core" prefix="c"%>
0
 
nitin22Author Commented:
Hi rrz,

Thanks for the reply, and here's what I did.

1. From the link I downloaded the 1.1.2.zip.
2. Unzipped it and copied the jstl and the standard jars into my projects WEB-INF\lib.
3. Removed the URI mapping from web.xml
4. Removed the c.tld file
5. replaced the URI in the JSP with the one you mentioned above.

But I am still getting that same error.

One more thing is that, I have deployed the web app exploded in weblogic server. I am not sure if this is something that's causing the error.

Looking forward to hear!

--Nitin
0
 
rrzCommented:
You did everything correct. Your JSTL installation is now correct. I can't explain the error.  Did you restart the server ?
>I have deployed the web app exploded in weblogic server. I am not sure if this is something that's causing the error.  
I don't think that would make a differance.
I am not a Weblogic expert. Hopefully one will help you.  
Meanwhile  look at
http://forums.oracle.com/forums/thread.jspa;jsessionid=8d92079330d678d22c19e8b14441832fa93c1da06d17.e38QbNuQbx8Kbi0LbhaMaxqTahj0?messageID=3325925� 
http://objectmix.com/weblogic/528645-classpath-isolation-weblogic-9-1-xerces-3.html

Weblogic expert needed.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
rrzCommented:
0
 
rrzCommented:
the last one works
0
 
nitin22Author Commented:
Hi rrz,

I did restart the server and nothing changes, still getting the same error.

I looked into the links above and none has a solution.

If you find anything on this, please post it. this has become a show stopper for me.

Thanks,
Nitin
0
 
nitin22Author Commented:
Hi rrz,

I solved it myself! :)

I had a <prefer-web-inf-classes> set to true in the weblogic.xml file. I removed that entry and the error is gone now!! So now it is using the weblogic server's jstl I guess and hence working fine.

Thanks for your help!

--Nitin
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now