• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 925
  • Last Modified:

SQL Reporting 2008 save report error message

Hi,

Whenever I try to save any report in report builder 2.0 I get the following error message:

An established connection was aborted by the software in your host machine
----------------------------
Unable to write data to the transport connection: An established connection was aborted by the software in your host machine.
----------------------------
The underlying connection was closed: An unexpected error occurred on a send.

If the database that the report takes it's reporting data from is on the same server as the reporting database I do not get this error, only if it is on a different server.

I'm assuming this must a permission issue, so my question is.

A.  Is there an error log or a trace file I can use to track this?
B.  Does anyone know specifically what this problem could be?

thanks
0
kinton
Asked:
kinton
1 Solution
 
Chris LuttrellSenior Database ArchitectCommented:
Found a couple links that might be helpful:
http://sharepoint2009.blogspot.com/2008/03/content-deployment-5323-and-4958.html
http://www.experts-exchange.com/Networking/Protocols/Transport/TCP-IP/Q_23711444.html
Maybe one of them will put you on the right track.  Not a lot of folks are into Report Builder yet and this sounds like a configuration or secruity issue.  Good luck.
0
 
kintonAuthor Commented:
Can this question be resolved as I have found the solution.

Had to phone Microsoft in the end.

This issue only occurs when you use SQL reporting 2008 and an SSL certificate.

Solution is below:

Problem
========
Cannot upload RDL file to SSRS using Report Builder 2.0.

Environment
============
Windows 2008 SP1
SSL is used.

Possible Root Cause
===================
The default request size of 16kb is not large enough to contain the full HTTPS request before the certificate is fully processed.
Since we try and flush the buffer but the cert is not fully negotiated the web server will tell the client to close the connection.

Suggested Resolution
====================
1) Add the registry key called "MaxRequestBytes" to "HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters" and set it to a value of 0n5242880 (5MB).
NOTE! One report I found said to set the value to 0n5242880 and another report said to set the value to 5242880 (without the leadin 0n).
You might want to try the second one as well should not the first resolve the issue.
2) Stop the SRS Service from Reporting Services configuration manager
3) Stop the HTTP service by typing "net stop http" from the command prompt.
4) Start the HTTP service by typing "net start http" from the command prompt.
5) Start the SRS service
6) Try uploading the Report from the report manager.


0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now