iGoogle home page always opens 2 other tabs in Fireforx

I have recently changed my home page to iGoogle.  I am using Firefox as the browser.  Whenever I click on 'home' it goes to iGoogle, then also opens 2 other tabs - one is the Google Accounts Password Assistance tab, asking me to reset my password, the other is a completely blank (untitled) tab.  It doesn't help if I go through the password reset, I have done that many times.

If I open IE and set iGoogle as my home page, it works fine.
MGothelfAsked:
Who is Participating?
 
war1Commented:
Hello MGothelf,

Try reseting your homepage.  Open iGoogle and no other tabs.  Go to Tools > Main.  Under current, select Use Current Page. Verify that there is no "?" after the URL address.  Click OK.

Hope this helps!
war1
0
 
Britt ThompsonSr. Systems EngineerCommented:
If you go to your Firefox preferences and set the homepage to default then type in http://igoogle.com it should clear the other 2 tabs it's opening. Also, try clearing your cache by going to Tools > clear private data > and de-select all but cache.
0
 
meispiscesCommented:
May be when you first modified/reset the home page to www.igoogle.com, you might had 2 tabs open. and when you closed the Mozilla Firefox, it asks for 3 options as (Save/Quit, Quit, Cancel) and if you press/select the first option Save/Quit, it would Quit the MF, and would open with same session (i.e same situation when you closed the MF) when you would open the Mozilla Firefox again..

So try closing both these tabs ( and not MF) and then close the Mozilla Firefox with Quit option selected. Then try opening the MF and have a look for igoogle.com Home Page

Hope that helped you

Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.