• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 300
  • Last Modified:

File system Issues

I have a Microsoft 2008 stan server, running raid 5 it has 4gb Ram and 2.8Ghz Dual xeon quad cores, gigabit ethernet.  The problem that I am having is that every now and than files become almost imposible to open under certan directorys under a network share from any workstation trying to open files under that certan directory.
 
For example:
X:\\data\Projects\2008\822002 - Howell Friendship Real Estate Company - Petsmart Store\CTL  Reports
The files in CTL Reports are inaccessable when you try to open a document regardless of what document type, it will
not open and usually freezes up the work station for over 10 min.

If I creat another file in the same dir as CTL Reports and then copy all of the data from CTL Reports to this new dir I have created the files open without an issue.   this is happening to all workstations on and off the domain, and only seems to be affecting the Projects Dir.  All dir's under projects have a CTL Reports dir at the same level as about 300 dir's under the projects dir.  Also the projects dir is the most used dir through out the day, and the only dir that seems to be affected are the CTL Reports dir's.  Not every CTL Reports dir has this issue.  

I ran wireshark on one workstation I was trying to pullup files on under a CTL Reports dir that I was having these issues with and was coming up with packets that said (maybe caused by TCP Checksum Offload) reapetedly with some good SMB packets inbetween?   not sure if this is something to look at or not because I see this anytime I run wireshark on my network.
0
nck534
Asked:
nck534
  • 3
1 Solution
 
ComputerTechieCommented:
Have you run a chkdsk the raid with on the folders it sounds like a corrupted files or a drive starting to fail in the raid. I would also check the users permission to see if someone is locking required files for the project until they close.

CT
0
 
nck534Author Commented:
I run a Check disk every Sunday, All the user permissions are correct.  The server is only 2 Months old it is a dell Power edge 2900 II. 3 500 gig hard drives running raid 5 split into 2 partitions. 80 gig for the OS and the rest for Data.

I have been having an issue with Group Policy though.  My workstations report Event ID 1058 and 1030 in the application log.  I have run rsop, gpresult and found that the default domain policy is not taking.  I am not sure if this could be a part of the file issue or not, and am not sure if i should run DCGPOFIX or if that would even fix the issue.  My DC's are getting there Domain controller policy fine, plus all other Domain policies are working fine.  
0
 
nck534Author Commented:
Note that worstations that are not on the
Domain are having the same issue as well
0
 
nck534Author Commented:
I have managed to fix this issue my self by listening to what Wireshark and NetMon was telling me about the TCP Checksum offloading errors.  I disabled all Offloading except Large send offloading, under the hardware properties of the Ethernet card.  I have had no issues after doing this for all clients and servers.
0

Featured Post

Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now