• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1300
  • Last Modified:

Wordpress Permalink / .htaccess Issue

I seem to be having an issue when I want to change the default permalink setting in Wordpress to a custom setting (i.e. /%postname%/). Whenever I make the change, my site no longer works (I keep getting a 404 error messages).

I looked into it a bit and think it may have to do with my .htaccess file. The issue is..well, I don't seem to have an .htaccess file! I have enabled my FTP client to show hidden files and there doesn't seem to be one in the directory I installed Wordpress. Should Wordpress have created one during my install or do I have to manually create one?

To be honest, I'm no whiz when it comes to server related issues so I'm not really sure what to do. Can I just create my own .htaccess file and put it in my directory? What information do I put in the .htaccess file?

I have looked over a related EE post created a little while back but a solution never came up:
http://www.experts-exchange.com/Web_Development/Blogs/Q_22705938.html

Also, as a reference, here is some info on Wordpress Permalinks:
http://codex.wordpress.org/Permalinks
Under the heading "Using "Pretty" permalinks", there are some details on issues with .htaccess and permalinks.

Any help would be much appreciated! Thanks.

P.S. BTW - not sure if this affects anything but my site is using Zeus web server
0
Adam
Asked:
Adam
  • 2
  • 2
1 Solution
 
souseranCommented:
You should be able to create an .htaccess file and upload it to the root of your server in the HTML directory. See the Creating and editing (.htaccess) section of the Codex article you linked.
0
 
AdamAuthor Commented:
I looked into a bit more and it seems like there is an issue with my Zeus server. Zeus I believe does not use .htaccess files. A rewrite script is one option to fix this issue. You can check out an example of a rewrite here:

http://www.jafferabbas.com/technology/activate-wordpress-permalink-on-zeus/
0
 
souseranCommented:
As this information would be handy for others to know, I request that furio13 be allowed to accept his own answer, 24291045, and close the question instead of deleting it. That way we can keep the answer as a PAQ. Thanks.
0
 
AdamAuthor Commented:
Sorry about that. I didn't realize I could select my own reply as a solution. Thanks for clearing that up.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now