[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 758
  • Last Modified:

IBM ThinkCenter laptop suddenly canont access the Internet either Wired or Wirelessly

She is running XP.
INternet was working fine.  It suddenly turned off about 5 days ago.  There may have been a Windows Update at that time.  She Is running SP3.
I expect my question description incomplete.  I don't know where to start.  I expect you to ask me more questions about the situation.  Here's what I know.
Someone called me and said their Internet wasn't working.  I went over there.  I brought MY laptop.  I pulled the Ethernet cable out of her PC and plugged it into my PC.  It worked FINE - I was able to access the Internet fine.  I also saw many Wireless networks but I didn't try any.
I puit the cable back in her PC and I couldn't access the Internet.  I shut down both firewalls - both Norton 360 and the build-in Windows XP firewall.
She has FIOS although I'm not sure that matters since my computer worked.
When I do IP config, it just prints "Windows IP Configuration" and returns to the prompt.
Now ... this ThinkPad has this "radio" control which is related to wireless.  It shows Radio Off.  There is a button that says "Turn Radio On."  I click the button and nothing happens.

I apologize for the unclear statement of the problem.  I expect you will have questions for me to answer.  I am currently imaging the PC - just to be safe.  When the imaging is done, I will try a PCMCIA card - see if that works.

0
DFlaschen
Asked:
DFlaschen
  • 10
  • 7
1 Solution
 
DFlaschenAuthor Commented:
OK.  This is too weird - unexpected results....
I took this laptop from it's owners house (FIOS) and brought it to my house.
I plugged in PCMCIA card.  After providing the driver and entering the WEP code, it worked fine.  No a big surprise, but good news.
Now here's the weird stuff.  I plugged in a LAN cable to MY network here and it worked fine. Why does my Comcast network work with her laptop but her FIOS network doesn't even appear to notice there's any network card in her computer?
Finally, I tried HER internal wireless card here (vs. the PCMCIA card) and it worked AFTER I said "Use Windows to configure my wireless network settings."  
I am tempted to say I "solved" the problems but I am not confident it will work in her enviroment.
My laptop worked in her FIOS environment.  Her laptop didn't work WIRED nor did it even SEE her wireless networks.  My guess is her laptop WILL now see her wireless networks now that I've said "Use Windows to configure my wireless network settings".
And my guess is her WIRED LAN will still fail in her FIOS environment - but that makes no sense to me.  I say this because my laptop works there and her laptop didn't even seem to know there was a network card in it.  IPCONFIG came up blank there!
I will attempt to test the laptop in her environment tomorrow but I still welcome comments, questions, observations, etc. until then.
0
 
Fatal_ExceptionCommented:
When it was not working on the FIOS, did you run any PING tests?  My standard 4 step procedure:

Step-1: Ping Loopback IP address (127.0.0.1). Success shows that TCP/IP is properly installed.

Step-2: Ping local NIC's IP address. Success shows that NIC is working properly.

Step-3: Ping Default Gateway. Success shows that local physical layer connections are ok.

Step-4: Ping Remote IP address. Success shows that remote physical layer connections are ok.
0
 
DFlaschenAuthor Commented:
When it was not working with FIOS i couldn't PING anything!
I did not try to ping 192.168.1.1
I did not know what the default gateway was because IPCONFIG showed nothing - and I mean nothing.
I have - sort of - got the laptop working here, at my office.  I am going to take it over to the FIOS site and see what works there (in about an hour).  I will report back later today.
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
DFlaschenAuthor Commented:
CLEAR STATEMENT OF PROBLEM:
The computers:
IBM THinkPAd T60 computer  (problematic)
Dell laptop  (no problems)
The environments:
FIOS network (problematic)
Comcast network (no problems)
The Network cards (in IBM ThinkPad):
Internal Ethernet LAN
Internal WIRELESS
PCMCIA WIRELESS
The symptoms:
The Dell works fine in both environments.
The IBM works fine - all 3 network cards - in the Comcast environment
The Dell works fine in the FIOS environment (Wired and Wireless)
The IBM FAILS to connect in the FIOS environment (none of the 3 cards work with FIOS).
Other information:
The PCMCIA card sees the available wireless networks.  The internal Wireless card does not.  Although the PCMCIA card sees the networks, it gets stuck "acquiring network address" and ultimately can not be used to connect to the Internet.
When the PCMCIA is connected I CAN Ping the local 192.168,.1.1 address but nothing else.
There is a Norton-360 firewall.  Disabling it does not change anything.
Sometimes the LAN Cable is unplugged message will pop up - and then go away.  Just sometimes.  This happened when I shut off the firewall.  It's random and infrequent, but probably significant.
When the PCMCIA card is in, IPCONFIG gives an expected result.
When the PCMCIA card is out, IPCONFIG shows NOTHING.
I have not yet updated the drivers.  I will do that now (on the Comcast network, obviously).
0
 
Fatal_ExceptionCommented:
After upgrading drivers, you might want to reset the Network Stack too...  

You may have to Restore this system back to its defaults..  On all of our Thinkpads, there is a Restore Partition...  also, I have found when upgrading these drivers, make sure you get the right one..  

http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-62928
0
 
DFlaschenAuthor Commented:
I cannot explain why I am getting different results today than yesterday, but these are my results:
The PCMCIA card works on my Comcast network but fails to "acquire an address" at the FIOS network.
I should also point out that the Wireless Radio shows Off when I press Fn + F5.  There is a button that says "Turn it on."  When I click the button, it stays Off.
How do I reset the Network Stack?
And, how do I restore the system back to its fault?
So, to summarize:
  The PCMCIA card works
  The internal wireless card can't find any networks (the PCMCIA finds several).
  The LAN Connection says "connected" but it doesn't allow me to connect.
The Radio is off but when I press Turn On, it doesn't turn it on.
When I press IPCONFIG, it shows NOTHING - except if PCMCIA is in the PC, then it shows normally.
0
 
Fatal_ExceptionCommented:
Regarding resetting the network stack:

netsh int ip reset resetlog.txt

but you might want to review this page first to see what the command does::

http://support.microsoft.com/kb/299357

Regarding Restoration, on our Thinkpads, the Recovery Partition is accessed using F11 at boot time.  But realize that this option can wipe out the entire primary partition (system)..  be sure you BACKUP your user's data before you go this route.

FE
0
 
Fatal_ExceptionCommented:
I found the document for the service partition on Lenova's site:

http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-4W5QVB

0
 
DFlaschenAuthor Commented:
I am guessing these problems began with the install of SP3.
http://www.google.com/search?hl=en&safe=off&num=30&q=lenovo+OR+thinkpad+SP3+wireless+t60
I am considering rolling-back SP3, if that's possible (don't know how to do it yet).
0
 
Fatal_ExceptionCommented:
Uninstall SP3?   Easy to do:

http://support.microsoft.com/kb/950249

0
 
DFlaschenAuthor Commented:
I am in the process of imaging the drive - and the backup-partition-drive.
Once that is done, I will try uninstallinig SP3.
If that fails, I can do some System Restores - I can go way back if necessary.
This computer is NOT used "fancy".  The owner does a little on-line shopping and writes a few Word documents - not much more.  So it is very simply configured (BTW: it runs XP Pro).
Thank you for your help so far.    David
0
 
Fatal_ExceptionCommented:
Hope you get this sorted out!  I am off to a remote office location to work on the routers, but will check back tonight.

FE
0
 
DFlaschenAuthor Commented:
I uninstalled SP3l.  It did not fix the problem.  Now, however, when I try to Repair either LAN or wireless connection, I get:  "Failed to query TCP/IP settings".  I have just tried your NETSH command.  I am about to reboot and see what happens.As far as the F11 Service Partition idea.  You've said it can wipe the entire primary partition.  That doesn't sound good.  I do have images of the drives, but ....
I'll reboot now and see if the NETSH command fixed anything.
Remember: Neither Wired nor wireless works.  The PCMCIA card works fine (but not on FIOS - only on Comcast.)
I see no Wireless networks.  IPCONFIG shows NOTHING.  It just returns to the Command Prompt.
This IBM Lenovo ThinkPad T60 has a "wireless radio".  It shows OFF.  All attempts to turn it on fail.
0
 
DFlaschenAuthor Commented:
Important comments:
Rebooting, it still didn't work (at first!).  When I said "View Available Networks", it told me how to choose "Use Windows to configure my wireless settings."  IMPORTANT  That's how I got wireless to work before in this Comcast environment.  But then it went away.  Deleting TCP/IP, I guess, made it come back.  
Think ThinkPad has some software on it called: "ThinkVantage Access Connections".  I think that is used for folks that take their laptops to multiple networks.  (This user never does that.  The laptop stays at her home, wired - not even wireless."
Finally, for the first time, since I started checking, the "Wireless Radio" is on.  This "radio" has a physical on-off switch on the front of the laptop.  It also has a software interface at Fn + F5.  Before now, you couldn't turn it on.  Now I can.
IMPORTANT:  I've gotten this laptop to work here, in my Comcast environment.  When I took it over to her FIOS environment.  It didn't work!!
Next test - and what I most need - is to see if it now works over the LAN cable.
I'll be back to you.
Feeling a bit optimistic.  Don't abandon me!  :)  Thanks.
0
 
DFlaschenAuthor Commented:
OK.  It now works WIRED (LAN) too.
Here are my concerns:
1.  When I take it over to HER house, it fails on FIOS.  That was what I may have experienced before.
2.  A future Windows update Kills it again.  I will take an image of it now, working but I am scared of that.
3.  Something else kills it.  Perhaps this ThinkVantage software.
Is there a way to tell it: Do NOT (ever) install SP3?  Can you tell Windows that?
Thanks,
David
0
 
DFlaschenAuthor Commented:
SOLVED - RESOLUTION:
Uninstalled ThinkVantage Access Connections.
This program is like a layer on top of Windows networking.  I believe it is designed for the type of user who needs to connect to different networks (BOston on Modays, Detroit on Tuesdays, home on Saturday etc.)
My machine was so screwed up.  The "radio" couldn't be turned On.
It didn't work wired (LAN) or wireless.
I think the problems were caused by some Windows updates - including SP3.  But removing SP3 didn't help.  And I put it back without killing things.
Resolution:  I unistalled Access Connections, which the user has no need for and it was fixed.
FE's NETSH suggestion got things going.  I would remove that and things would work.  Then I'd reboot and they'd fail again.  I thought "do I need this (rotten) program?"  "No.  I don't.  So I removed it.  Then the fixes stuck.
0
 
Fatal_ExceptionCommented:
Ha!  Great to hear, and glad I could be of some small help!

FE
0

Featured Post

New Tabletop Appliances Blow Competitors Away!

WatchGuard’s new T15, T35 and T55 tabletop UTMs provide the highest-performing security inspection in their class, allowing users at small offices, home offices and distributed enterprises to experience blazing-fast Internet speeds without sacrificing enterprise-grade security.

  • 10
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now