• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 925
  • Last Modified:

Configuring SSL for OWA/ActiveSync

Exchange 2003 OWA working great when SSL is not forced. I have an SSL Cert in place. When I force SSL for "Default Site" and enable Form Authentication the page can not be displayed. This is a stand alone Exchange 03, on Server 03. Any advice would be appriciated to bring SSL up in OWA and ActiveSync. Thanks.
0
TSCF_EMS
Asked:
TSCF_EMS
  • 8
  • 5
1 Solution
 
tompi68Commented:
May be this step by step guide helps you out

http://www.petri.co.il/configure_ssl_on_owa.htm
0
 
TSCF_EMSAuthor Commented:
I have went through this procedure before, and when I do enable SSL I can not access the OWA within the LAN or the WAN. However, when I try to access the OWA via HTTP (with SSL enforceed) I do get the error that HTTPS is required to access the page (LAN and WAN).
0
 
TSCF_EMSAuthor Commented:
A note to add.
Server 03/ Exchange 03 server is sending and receiving email just fine. If you want to run HTTP(S), DNS, MX diagnostic the domain is tscfems.com.
MX= MAIL2.TSCFEMS.COM
OWA URL:= mail2.tscfems.local
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
TSCF_EMSAuthor Commented:
Sorry.
OWA URL = tscfems.com/exchange
0
 
ikshf143Commented:
HI There,

IF i am not wrong then the Exchnage server ia a 2003 server, so in that case I wouldn't force SSL on the default web site instead force it on Exchange and Microsoft-Server-ActiveSync virtual directories for OWA and activesync respectively

Try this:
Install the certificate on Default Web Site and uncheck require SSL for the Secure communication and from the server itself open a web browser and enter https://localhost and see what happens, if this fails then there might be some issue with your certificate and you might need to fix that.

Imran
0
 
TSCF_EMSAuthor Commented:
I have tried your suggestions and I get the same results. The cert was issued by godaddy. I even had them re issue it again to make sure the cert was valid. Strange thing is that HTTPS for OWA was working about two weeks ago without a cert installed. I tried to replicate that again and still no go.
0
 
ikshf143Commented:
So, if you tried https://localhost then it is the same error Page Cannot be Displayed. If this is the case then Go to the properties of the default web site and check if we have the SSL port configured for it. if then go to the security tab of the Web Site and click view certificate and make sure you see a Private Key on the certificate, I mean check out the General Tab and at the bottom of the certificate and it would state that "you have a private key assigned to this Certificate"
0
 
TSCF_EMSAuthor Commented:
True, however if I did not have a cert installed I should still be able to view an SSL site locally or publicly by self signing, correct?
0
 
ikshf143Commented:
If you do not have a certificate or port 443 configured on your website then you won't be able to view your site locally or pulically over SSL, these 2 things are the basic requirement for a site to view it over SSL but you can view other sites like https://www.gmail.com
0
 
TSCF_EMSAuthor Commented:
I do have the site configured for port 443. To narrow it down a bit further I created another site, configured for port 443 and tried to access it. No go. Do I need to reinstall IIS?
0
 
ikshf143Commented:
The site which you have configured for port 443 should also have the Certificate installed. Is that the case, If so then go to the properties of the Web SIte > Directory Security > View Certificate and see if you can see the a statement at the bottom of the certificate below the Validity Period that would say"This Certificate has a Private Key assigned"
0
 
TSCF_EMSAuthor Commented:
I do not see anything below the issue dates. Attached is a screen shot.
1.jpg
0
 
ikshf143Commented:
This can be one of the cause for the issue. Try following the Microsoft KB article http://support.microsoft.com/kb/889651 to resolve the private key issue.
0
 
TSCF_EMSAuthor Commented:
This worked great. OWA over HTTPS is working fine now. Thank you for your help.
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

  • 8
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now