Dlink DPR 1260 print server has quit working

Posted on 2009-04-27
Last Modified: 2012-05-06
This print server has worked flawlessly for 18 months along with an HP Color LaserJet 2605dn. The last week I've had to cycle the print server nearly every day to print, which has been inconvenient, but it's worked. Now, suddenly, the print server shows only the power light: no wireless light, and no USB connection with the server, and nothing prints.

The printer prints fine when connected via USB with my laptop, so I've ruled out a printer problem.

I cannot connect with the Dlink print server via the IP, or via the http://dlinkps-xxxxxx. I've reset the unit (I think) but I just get bupkiss.  Also, it doesn't show up in my Network Places (Win XP SP3).

The print server is independent of my wireless router. It is just connected to a single printer and accessed by two laptops.

Any help would be appreciated.
Question by:FunkyBF
    LVL 87

    Expert Comment

    Doesn't that printer already have a NIC included? HP Printers with an "n" in it's product number usually do, so why do you need a separate printserver? Just setup the NIC of the printer and connect it to the LAN. If you need to connect it through wireless, use an access point.

    Author Comment

    Rindi, I use a wireless router but it sits in the main room of my apartment, by the cable access. I have the printer in my office. So I can't plug the printer directly into the wireless router. For that reason, I bought an inexpensive print server, which has worked well up until now.

    It seems like a hardware issue, like the Dlink 1260 just kind of died, but this guy resurrected his on this thread, which gives me hope:

    Unfortunately, I've been unsuccessful following the directions in that thread.

    Accepted Solution

    I searched around and figured out that, despite the fact that I was holding the reset button for long times (up to a minute) the unit still was not resetting. I found a solution to that on I held the reset button (with a golf tee) in the back for about 30 seconds, released it, and immediately unplugged the unit for about 10 seconds. When I plugged it back in, it started printing documents in the print queue.


    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    Last Mile Wireless The term last mile wireless is a bit deceptive as it can be much more than a mile. It is also called WiMax and 802.16. It generally refers to relatively short distance point-to-point / point-to-multipoint secure wireless connecti…
    This article is a step by step guide on how to create a basic PTP link using Ubiquiti airOS devices. This guide can be used on the following Ubiquiti AirMAX devices. Nanostation, Bullets, AirBridge, Nanobeam, NanoBridge to name a few. Please review …
    It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
    Internet Business Fax to Email Made Easy - With eFax Corporate (, you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now