[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4024
  • Last Modified:

MS Exchange OAB error, Not Downloading Offline Address Book Files (0X8004010F)

I have been getting the 'Not downloading offline address book files.  A Server (URL) could not be located.' error in Outlook since moving from Exchange 2003 - 2007 and I have almost sorted it.  This article describes how to fix it (http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_23815051.html?sfQueryTermInfo=1+10+address+book+download+file+offlin)

But all I need is the correct syntax to enter in ADSIEDIT.MSC.

If my server is called server1.mydomain.com what EXACTLY do I need to enter in the msExchUseOAB field?  Thanks!!
0
-Juddy-
Asked:
-Juddy-
1 Solution
 
ikshf143Commented:
The best way to change the OAB URL would be from Exchange command shell. Follow the following Microsoft KB article and change the URLs of the server to the Issued to name of the certificate.
http://support.microsoft.com/kb/940726.
0
 
-Juddy-Author Commented:
Ok guys, there's an awful lot of information in those, but as far as I can see nothing that exactly matches what I want.  My OAB is located here:

\\server_name\ExchangeOAB\eacd6ae0-eaf4-47e1-bd7c-13a13a51f780\oab.xml

so in the msExchUseOAB field do I add the above, or does it start https://

Is using adsiedit.msc the best way to do this, or do i run a command from the Exchange Powershell?
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
Rajith EnchiparambilOffice 365 & Exchange ArchitectCommented:
0
 
-Juddy-Author Commented:
The above KB articles fixed it for me, my ADSIEDIT.MSC reports the correct data for my OAB.  Bad news is that I am still getting the synch error, do I need to re-start any services?
0
 
ikshf143Commented:
From an Outlook 2007 client try to run the test Email autoconfig and see if Autodiscover is working, if yes then what is the URL it returns for OAB. Also check in IIS manager under default web site-->OAB if we have a folder which would look the same as the folder under ExchangeOAB\eacd6ae0-eaf4-47e1-bd7c-13a13a51f780. From IIS try to browse oab.xml and see if that shows up fine. Check if we have the OAB selected for web distribution from EMC > Organization Configuration > Mailbox > Offline Address Book > Properties of Default OAB > Distribution.
0
 
-Juddy-Author Commented:
The OAB URL it reports is the correct path (minus the OAB.XML) at the end.
In IIS there is a folder called the same.
It shows up, here's an example of some of the text (is this ok?):
 <?xml version="1.0" encoding="UTF-8" ?>
- <OAB>
- <OAL id="e493ba13-3c7b-4ffc-b871-d3004548755f" dn="/" name="\Global Address List">
  <Full seq="3" ver="32" size="3298" uncompressedsize="23540" SHA="84ee4799bd4890c3ec8832103683656c4d7d9b1e">e493ba13-3c7b-4ffc-b871-d3004548755f-data-3.lzx</Full>

OAB is indeed setup for web-based distribution (and public folder distribution).

i have just noticed that I haven't had a Synch error in Outlook for a while, but I'll monitor it just in case.  Does everything (above) appear to be in order?


0
 
ikshf143Commented:
Yes, they all seem to be fine. Check these few things as well. Try to browse the URL that you see in the test email autoconfig for OAB till the OAB.xml and see if you can the same response as you got when u browsed it before.
Run the following command in the Exchange Management shell
Get-OABVirtualDirectory | FL and check for internal URL, Authentication(should be Integrated Windows). On the Mailbox store do to the properties of the database and select client settings and see if you have the correct OAB selected.

Do you have multiple OABs created or is it the Default one only
0
 
ikshf143Commented:
with reference to the above post, when you run the Get-OAB command in the shell also Check the require SSL part and that should be disabled.
0
 
-Juddy-Author Commented:
The URL is (as per test e-mail autoconfig):

https://server.my-domain.com/oab/eacd6ae0-eaf4-47e1-bd7c-13a13a51f780/

If I browse using Windows Explorer it just shows the contects of the folder, including the OAB.XML.  If I use IE to browse I get:

500 - Internal server error.
There is a problem with the resource you are looking for, and it cannot be displayed.

The command does indeed return <Windows Integrated>
The correct OAB is selected and we only have one.
Require SSL is set to: TRUE.

By the way I have just checked again and there are still no synch issues.
0
 
-Juddy-Author Commented:
We do have a valid, third party SSL certificate installed by the way.
0
 
ikshf143Commented:
try browsing this from the client, https://server.my-domain.com/oab/eacd6ae0-eaf4-47e1-bd7c-13a13a51f780/oab.xml and disable SSL by running the following command
Set-OabVirtualDirectory -Identity "OAB (Default Web Site)" -RequireSSL:$false

Is the name on the certificate and that returned from test Email auto config same?
0
 
-Juddy-Author Commented:
The test returns the FQDN of the mail server which is included on the certificate as an alternative.

If I browse from my laptop to the mailserver using IE I get the 500 - internal server error.

If I use Explorer I get asked for a username / password.  I tried using my Exchange login, but it fails.

Do I really need to disable  SSL for the OAB?
0
 
ikshf143Commented:
Well it is optional but recommended is to disable it. ok try the following and see if you have any luck

Delete and recreate the OAB Virtual Directro by running the following commands. Take a backup of the Default Web Site before doing this just to be on a safer side.
Remove-OabVirtualDirectory "OAB (Default Web Site)" to delete and
New-OABVirtualDirectory to recreate it.

After recreating it again Enable the web distribution and select the OAB directory there. Restart the MSExchangeFileDistribution service and the Background Intelligent Transfer Service and the Guid will get regenerated under the OAB in IIS

If this doesn't help

Try creating a new OAB in EMC > Organization Configuration > Mailbox > Offline Address Book and name it TEST or anything u like and select the OAB generation server and select the Default Global Address List. Enable Web Based distribution and select the OAB VDir. Once done right click on it and set it as default. wait for some time and let it populate itself

Then Restart the MSExchangeFileDistribution service and the Background Intelligent Transfer Service and the Guid will get regenerated under the OAB in IIS. Now try to access oab.xml under this guid from the client if that works then you should be able to download OAB.
0
 
ikshf143Commented:
With reference to the above if you are creating a new OAB then you will have to change the settings of the mailbox database. Go to properties of the database and select client settings and change the Default OAB to the new one
0
 
-Juddy-Author Commented:
I think we are in business.  I deleted and re-created a brand new OAB, made it default, enabled web distribution, restarted service and i can now see it from my laptop, allbeit a garbled XML document.  Is that what I'm looking for?

One note though, I didn't tick the 'Enable public folder distribution' option with this, new OAB.  Is that a problem?
0
 
-Juddy-Author Commented:
Just got three new sych errors and the OAB does not show up when I run Testemailautoconfig any more.  Sigh..........
0
 
ikshf143Commented:
Yes that is the XML file we are looking for. Also if you have not selected Enable Public folders that is not an issue unless you don't have any Outlook 2003 or older clients in the Organization. If you have them then you need to enable Public folder distribution
0
 
-Juddy-Author Commented:
No more synch errors since my last post, so I think it's all sorted.  Many thanks for your excellent help!
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now