Removable storage service problems

Hi Guys,

I'm having a problem with a server's backup. The backup fails with the error "unable to mount selected media". I have changed out the DAT72 tape drive for a brand new tested fully funtioning one and keep getting errors.

To fix this so far, I've been having to stop the service, reboot the server and remove the RSM DB files from the system32\ntdsm folder, restart the service and it works, though the next day the same happens.

i've been looking but can't seem to find any guides on reinstalling this service as removing the DB doesn't seem to be providing a long term fix.

My question is, does anyone know of any way to completely reinstall this service? Or even better have any easier solutions?

Cheers
LVL 2
ConanUKAsked:
Who is Participating?
 
ConanUKAuthor Commented:
After removed all hardware & software and reinstalled drivers and remaking a clean RSM DB it's ran perfectly!
0
 
JBlondCommented:
Do you checked the eventlogs for errors that are related to this issue? If there are some events please post them here.
0
 
ConanUKAuthor Commented:
This is the only log that's shown:

Event Type:      Error
Event Source:      SmallBusinessServer
Event Category:      SBS Backup
Event ID:      5634
Date:            29/04/2009
Time:            23:33:48
User:            N/A
Computer:      IGSBS
Description:
One or more components of Small Business Server Backup failed. For more information, click Backup in Server Management, and view the log files.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

It run's fine the night after I redo te RSM DB, the next day it's broken. Tape drive has been cleaned and is brand new, tapes have been verfiied to work fine in other tape drives too!


Cheers.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.