?
Solved

How to get winbind to show the domain in user and group listings

Posted on 2009-04-28
2
Medium Priority
?
2,105 Views
Last Modified: 2013-12-02
On an old file server which has samba 3.0.7-2 and authenticates against a NT4 domain controller showing the owners of files causes the domain to be displayed so you can easily see that it cones from the windows domain and is not a native unix group. Also :-
[root@file2 samba]# wbinfo -g
BUILTIN/System Operators
BUILTIN/Replicators
BUILTIN/Guests
BUILTIN/Power Users
BUILTIN/Print Operators
BUILTIN/Administrators
BUILTIN/Account Operators
BUILTIN/Backup Operators
BUILTIN/Users
MYDOMAIN/Accounts
MYDOMAIN/General

I have setup a new server and configured it to authenticate against a SBS 2003R2 server and this is all working fine however the domain is not showing. For example :-

[root@file3 shares]# wbinfo -g
BUILTIN/administrators
BUILTIN/users
iis_wpg
helpservicesgroup
telnetclients
wins users
domain computers
domain controllers
schema admins

I have added the winbind separator and restarted winbind and samba but it is still not showing. Am I missing something?

# testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[printers]"
Processing section "[dump]"
Loaded services file OK.
Server role: ROLE_DOMAIN_MEMBER
Press enter to see a dump of your service definitions
 
[global]
        workgroup = TEST
        realm = TEST.LOCAL
        security = ADS
        password server = testsrv.test.local
        idmap uid = 16777216-33554431
        idmap gid = 16777216-33554431
        winbind separator = /
        winbind enum users = Yes
        winbind enum groups = Yes
        winbind use default domain = Yes
        cups options = raw
 
[homes]
        comment = Home Directories
        read only = No
        browseable = No
 
[printers]
        comment = All Printers
        path = /var/spool/samba
        printable = Yes
        browseable = No
 
[dump]
        comment = General area for MIS use
        path = /shares/dump
        valid users = @TEST/mis
        force group = TEST/mis
        read only = No
        force create mode = 0665
        force directory mode = 0774

Open in new window

0
Comment
Question by:grblades
2 Comments
 
LVL 81

Accepted Solution

by:
arnold earned 2000 total points
ID: 24256909
Just try to alter:
winbind use default domain = Yes
To
winbind use default domain = no

using the yes option, the user do not need to provide the AD domain when loging in, but when listing the domain is likely omitted.

http://www.ccs.neu.edu/home/battista/documentation/winbind/winbind.html
0
 
LVL 36

Author Closing Comment

by:grblades
ID: 31575413
Thanks that was exactly the problem.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In part one, we reviewed the prerequisites required for installing SQL Server vNext. In this part we will explore how to install Microsoft's SQL Server on Ubuntu 16.04.
I have written articles previously comparing SARDU and YUMI.  I also included a couple of lines about Easy2boot (easy2boot.com).  I have now been using, and enjoying easy2boot as my sole multiboot utility for some years and realize that it deserves …
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses
Course of the Month16 days, 10 hours left to enroll

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question