• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 528
  • Last Modified:

Module in template position Joomla

Hii there, faiIirly new into joomla .  I would like to have a module that displays a news rotator on everysingle page so I copied this module and put it on several pages on header position so when someone clicks on link read more goes to different section and show the module copied on header module postion. I am sorry dont really know how to describe the situation If someone could loock into my site,


  • 4
  • 3
1 Solution
Hello I need some clarification to see if I can help you,

Do you want to change the position of this module?
Or are you trying to get your users to a particular section  when they click on the currently displayed text?

Could you also tell me the name of the extension you are using to display the news scroller.


RickyGtzAuthor Commented:
Hello, thanks I thouhgt never find a joomla expert here., The module I am using is called

Gavick News Image VI -- mod_gk_news_image_6

I am trying to use it on each main section on the top in the  header1 module position of my template.
Now when I assigned to a menu item and then copy that link into the module : News image VI. The link shows no Module at the top. But if i use same link on top menu it does show it... ?

RickyGtzAuthor Commented:
Quick Update - went to modules creator site and the issue is something like:

IS there away of replacing the "&" with just "&" in the READMORE links for News Image 6.

The problem is the "&" stops the article being shown with the assoicated module. It strips out the paths.

The "Make Title a Link" works, but when the Readmore is enabled, it adds in the additional ampersand characters.


This works

This doesn't
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Ok I think I am following you now.

If I am correct your problem is that when you enter a url in the module it does not work because the module is intrepreting it incorrectly.

If this is the case then you can switch to search engine friendly urls quiet easily.
Instead of a long url like this  


Joomla will produce an more easily readable url like yoursite.com/news/latest.htm

Go to global configuration and under SEO Settings choose Search Engine Friendly Urls. You will need to remove the .txt from the mod_rewrite file using ftp or your hosting providers file manager.

RickyGtzAuthor Commented:
Is there any possible solution on this. The thiunk is SEF activated will make the componetn jom social fail...?
A key part of SEO is the mod_rewrite file which sets the rules for how the url is to be rewritten.  It can be edited to rewrite any part of the url for example change the &amp to  an ampersand (&).

If the turning on the seo causes problems. Just turn it off again and you are back to where you are now. It will not kill other modules or overwrite anything on your site.

Tip: Read the contents of the mod_rewrite file to see how to configure it. (the default is fine for most setups)
RickyGtzAuthor Commented:
hi, I have access through it in my ftp client. can you tell me where to modify settings or could you make the changes I need to display the page, have you go to the site feedmystream.com and entertainment section to see it live?

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now