Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1147
  • Last Modified:

Citrix ICA - Standard Desktop - mapping a usb cd-rom

We have many users on HP thin clients accessing a citrix published desktop.
I can map a CD-ROM and get it to show up in a standard desktop session, but when I access it I get access denied.  I can't even browse the device.  It is accessable on the thin client.

I can map a USB flash drive and access the files normally.

Does anyone have a solution?
Thanks!
deX
0
dhadmin
Asked:
dhadmin
  • 2
  • 2
1 Solution
 
Daniel BorgerSenior Citrix Engineer- CCEECommented:
First off, did you make sure there was a disc in the drive?  I have seen this with Citrix local drive permissions. You didn't mention the version of Citrix but if it's not the newest there is a webica.ini file that is local on workstation. verify that file has this setting,
 [Access]
GlobalSecurityAccess=405
Also, you can choose to delete this file and citrix will prompt you about sharing your drives and the type of access.
If you are are running 4.5 and desktops you can change the settings on the title bar at the top,
untitled.bmp
0
 
dhadminAuthor Commented:
dborger:
We're using ICA client version 10 and presentation server 4.5

My options are greyed out when I try to access this.  Is this b/c of a server policy.
ICA.jpg
0
 
Daniel BorgerSenior Citrix Engineer- CCEECommented:
Could be a Ctrix policy applied to that server. (see management console)
Could be a setting on the ICA protocol, Check properties in terminal services configuration.
 Were you ale to locate the webica,ini file?  if you do find it  rename it and try again.
0
 
dhadminAuthor Commented:
That's exactly what it was.  A partner of ours actually pointed it out, but that's the solution.  Here's a screenshot of the location.
ICA2.jpg
0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now