• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 500
  • Last Modified:

problem in display contents when using cfpod control

this code works (file name: pod1.cfm):

<cfpod name="myFirstpod" title="My First Pod">
 This is a simple CFPOD.  Similar to a DIV...
</cfpod>


the following NOT work:

file name: pod2.cfm:
<cfpod title="Pods with Ajax content" width="300" height="200" source="content1.cfm" />

filename: content1.cfm:

<cfoutput>
<p>
This is the content. <br />
Here is the random number: #randRange(1,100)#
</p>
</cfoutput>

I save content1.cfm file with pod2.cfm in the same folder.  The problem is when I use the source attribute, the animated icon appears then disppears.  No contents display.

0
monica73174
Asked:
monica73174
  • 5
  • 3
  • 2
1 Solution
 
erikTsomikSystem Architect, CF programmer Commented:
the the source provided . Different versions on CF required to use physical path rather than relative
0
 
monica73174Author Commented:
We have coldfusion 8
0
 
erikTsomikSystem Architect, CF programmer Commented:
tr putting absolute path
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
monica73174Author Commented:
I tried the absolute path, and got error, please see attach file. thanks.


error0409.JPG
0
 
azadisaryevCommented:
the code you posted works just fine.
what EXACTLY is in your content1.cfm? the error implies that you have some invalid code in it, most likely some javascript...

did you try what the error message suggests? :
add ?cfdebug to the url of your page that has cfpod in it
(NOTE: you need ajax debugging enabled in cf admin to see the debugger popup window)

Azadi
0
 
monica73174Author Commented:
Here is the content1cfm:

<p>
 This is a simple CFPOD.  Similar to a DIV...
</p>

I also enabled ajax debugging in cf admin and add ?cfdebug to the url and still not able to display content.
0
 
azadisaryevCommented:
hmm... do any other cf8 ajax controls work on your site? cfwindow? cfdiv?

if they do not - check the cf mapping for /CFIDE is correct and that you have a virtual dir setup to {cf_root}\wwwroot\CFIDE in your web server...

Azadi
0
 
monica73174Author Commented:
None of works if I used source attribute, without source attribute, it works.
0
 
monica73174Author Commented:
The Mappingst:

Logical Path                                 Directory Path
--------------                                 ------------------------------------
/CFIDE                                         E:\InetPub\wwwroot\CFIDE

Do you see any problem in this coldfusion Admin setting?
0
 
azadisaryevCommented:
hmm... per-se, that mapping should not be a problem, as long as that is where the CFIDE folder is located... i personally would not, for security reasons, put CFIDE folder in a web-accessible area, but that is a totally different matter...

if, as you say, the page you use as source for cfpod is in the same folder as the page that has cfpod in it, then it can't be an access permissions issue...
if so, i think i only have one suggestion left: make sure your cf server is patched up with latest hotfixes and updates. i do not remember source attribute being an issue, but it may very well have been and was solved in one of the hotfixes...

here's a link to cf hotfixes page: http://go.adobe.com/kb/ts_kb402604_en-us

Azadi
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

  • 5
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now