• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1048
  • Last Modified:

Exchange 2007/outlook 2007 Out of Office server is unavailable

I'm receiving this out of office error where the server is unavailable.  I've gone through the whole web and dont' seem to be a security problem.  Here is what i get when i do a get-outlookwebservices | fl

Id      : 1003
Type    : Information
Message : About to test AutoDiscover with the e-mail address e-mail@domain.com
Id      : 1007
Type    : Information
Message : Testing server domain with the published name https://domain/EWS/Exchange.asmx & .

Id      : 1019
Type    : Information
Message : Found a valid AutoDiscover service connection point. The AutoDiscover
           URL on this object is https://domain/autodiscover/autodiscover.xml.

Id      : 1013
Type    : Error
Message : When contacting https://domain/autodiscover/autodiscover.xml received the error The underlying connection was closed: An unexpected error occurred on a send.

Id      : 1013
Type    : Error
Message : When contacting https://domain/autodiscover/autodiscover.xml received the error Authentication failed because the remote
          party has closed the transport stream.

Id      : 1006
Type    : Error
Message : The Autodiscover service could not be contacted.


Any help would be appreciated.

Thank you
0
ymenational
Asked:
ymenational
  • 5
  • 3
  • 2
2 Solutions
 
jawad1481Commented:
HI!

CAUSE:
======
Incorrect configuration of Autodiscover virtual directory in Metabase.

RESOLUTION:
===========

Autodiscover Virtual Directory properties . . .Virtual Directory Tab. .
.Application Pool was grayed out and we cant make any changes in it.

1) Run IIS 6.0 Metabase Explorer from IIS 6.0 Resource Kit (Need to download
separately)
2) Go to ==> Start ==> Programs ==> IIS Resources ==> Metabase Explorer ==> Launch
Metabase Explorer.
3) Expand LM ==> W3SVC ==> 1 ==> Root ==> Autodiscover ==> In the Right pane
Name : AppRoot
DataType : String
Data : It was /Autodiscover so we changed it to
/LM/W3SVC/1/ROOT/Autodiscover.
4) Restart the IIS services or Perform an iisreset.


let me know if this works.

0
 
ymenationalAuthor Commented:
thanks jawad1481.

 I checked through the settings and it was the exact same as how you had it.  the data was already /lm/w3svc/1/root/autodiscover.

0
 
jawad1481Commented:
do you have exchange server 2003 ?

please if you have disabled public folder referrals and also if the clients are pointing towards exchange server 2003, point it towards exchange server 2007.

0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
jawad1481Commented:
Can you try to connect to that url with explorer
<https://autodiscover.nortrax.com/autodiscover/autodiscover.xml
And see the error you get & 
It should be something like
<?xml version="1.0" encoding="utf-8" ?>
<Autodiscover
xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
<Response>
<Error Time="12:13:02.9416830" Id="3179610563">
<ErrorCode>600</ErrorCode>
<Message>Invalid Request</Message>
<DebugData />
</Error>
</Response>
</Autodiscover>


Try this
Run the command to recreate the Autodiscover virtual directory
1. Remove-AutoDiscoverVirtualDirectory -Identity "<CAS_servername>\Autodiscover
(Default Web Site)"
2. New-AutodiscoverVirtualDirectory
Later set the AutodiscoverServiceInternalURI to internal FQDN name of the CAS
server as follows:
Set-ClientAccessServer -Identity "<CAS_servername>\Autodiscover (Default Web Site)"
-AutodiscoverServiceInternalURI
"<https://<Internal-FQDN_name_of_CAS>/autodiscover/autodiscover.xml >"
Also make sure that ASP.NET v2.0 is set to Allowed under Web Services Extensions
 

0
 
Sourabh-ExcahngeCommented:
please let me know if this is happening internally or for the external clients
if it is for the internal clients if you are able to create profile using autodiscover.
if you are bale to do so please run the test outlookconnectivity test from outlook client
press control button and right click on the outlook icon on the task bar just beside time
and then check what is the OOF url you are getting
and try to brows the same url from the same client machine and check if u get a XML page
0
 
ymenationalAuthor Commented:
Thanks for the responses.  

I dont want to remove teh autodiscovervirtual directory yet because it was working previously to our certificate expiration.  We renewed the certificate and our out of office and viewing others calenders is not working anymore.  OOF does work from the OWA.  

I changed some DNS settings and now I have this error. running the test-outlookwebservices command

Id      : 1003
Type    : Information
Message : About to test AutoDiscover with the e-mail address EMAIL
Id      : 1007
Type    : Information
Message : Testing server ymemscas01.loc.y-me.org with the published name https:
          //FQDN/EWS/Exchange.asmx & .

Id      : 1019
Type    : Information
Message : Found a valid AutoDiscover service connection point. The AutoDiscover
           URL on this object is https://FQDN/autodiscover/autodiscover.x
          ml.

Id      : 1013
Type    : Error
Message : When contacting https://FQDN/autodiscover/autodiscover.xml rece
          ived the error The remote server returned an error: (401) Unauthorize
          d.

Id      : 1006
Type    : Error
Message : The Autodiscover service could not be contacted.

I have ran the outlook conectivity test and i get autoconfiguraion was unable to determine your settings.

0
 
jawad1481Commented:
A valid test to check the problem would be:

On the CAS server try the following URLS using IE on CAS server:

https://certificatename/Autodiscover/Autodiscover.xml. : It will prompt for
credentials. After prompting a couple of times we get the following error:

Error: Access is Denied.

https://localhost/Autodiscover/Autodiscover.xml : It will work fine and give an
output.

We were running into a problem on IIS. To test further we will give integrated auth on
iisstart.htm and tried the following URL:

https://certificatename/iisstart.htm , if this fails than please follow the artile below and try the second method.

http://support.microsoft.com/?id=896861.
0
 
Sourabh-ExcahngeCommented:
it looks like your Autodiscover is not working
-- got to CAS server nad try to brows autodiscover.xml page using Https it should give you error 600.
please let me know the results
0
 
jawad1481Commented:
HI!

I think you will have to re-create the autodiscovervirtual directory as mentioned by me earlier.

Try this
Run the command to recreate the Autodiscover virtual directory
1. Remove-AutoDiscoverVirtualDirectory -Identity "<CAS_servername>\Autodiscover
(Default Web Site)"
2. New-AutodiscoverVirtualDirectory
Later set the AutodiscoverServiceInternalURI to internal FQDN name of the CAS
server as follows:
Set-ClientAccessServer -Identity "<CAS_servername>\Autodiscover (Default Web Site)"
-AutodiscoverServiceInternalURI
"<https://<Internal-FQDN_name_of_CAS>/autodiscover/autodiscover.xml >"
Also make sure that ASP.NET v2.0 is set to Allowed under Web Services Extensions
0
 
ymenationalAuthor Commented:
we had to reinstall asp.net some how it broke according to microsoft.
0

Featured Post

Granular recovery for Microsoft Exchange

With Veeam Explorer for Microsoft Exchange you can choose the Exchange Servers and restore points you’re interested in, and Veeam Explorer will present the contents of those mailbox stores for browsing, searching and exporting.

  • 5
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now