• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1196
  • Last Modified:

Update office 2007 configuration with new .msp not working. Cached Exchange mode/profile creation issues

1ST PROBLEM...

We deployed office 2007 using an .MSP file.  We did not disable cached exchange mode.  We edited the .msp file and changed it so that it sets the default behavior for cached exchange mode to disabled.  We did this by selecting, "Configure Cached Exchange Mode" and unchecking "Use Cached Exchange Mode."

It is my understanding that this will disable cached exchange mode by default so that it would need to be manually turned on in the profile.

If I just double click the new .msp file and run it and check the event log it shows as completed successfully but afterwards if I try to create a new mail profile manually cached exchange mode is turned on by default.  I have to manually go in to the profile and turn it off after creation.

It does not appear that rerunning the edited .msp resolves the issue.

ALSO, 2ND Problem....


I also have "Configure an Exchange Server Connection for new or existing profiles" selected and have set %username% as the username and the exchange server name for the server.  I also checked "Overwrite Existing Excahnge settings if an exchange connection exists."  I also have Modify Profile selected to modify the default profile with these settings.

For some reason when I try to create a new profile or it tries to autocreate if none exists it gets stuck on the server name and cannot make a connection.  The MS Exchange Server name field gets populated with this:  /O=xxxxxx xx/OU=MIL/cn=Configuration/cn=Servers/cn=xxx-xxxx  instead of the actual DNS server name.  If I manually clear that string out and just enter the FQDN or even just the name of the exchange server it works perfectly.  Where is that string coming from?  Why is it not taken from my configuration in the .msp file?
0
NBF
Asked:
NBF
  • 9
  • 8
1 Solution
 
GWMerrellCommented:
Have you ran your Office 2007 MSP install on a clean machine?  Does it force the profile to cachemode?
Do you have a group policy enabled which could be tatooing the registry for cachemode?
0
 
NBFAuthor Commented:
There is no GPO to configure cached exchange mode only customer experience program disable.

According to technet the following setting disables cached exchange mode in the .msp editor.

Select the Use Cached Exchange Mode check box to enable Cached Exchange Mode for users. By default, Cached Exchange Mode is disabled if you do not select the check box but you do select Configure Cached Exchange Mode.

I have UNCHECKED the use cached excahgne mode check box and selected CONFIGURE CACHED EXCHANGE MODE just as suggested.  It just does not flat out work.  

I tested on a brand new installation.  I even tried with SP2 slipstreamed in to the installation.  I have also tried to rerun the .MSP file after the install and no matter what I do, when I create a new outlook profile for an exchange mailbox, I have to go back in to the profile and manually uncheck the cached mode setting because it is on by default.

Any other suggestions?
0
 
NBFAuthor Commented:
By there is no GPO I mean we have no Office 2007 GPOS configured other than disabling RSS and Cust Imp Program.
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 
NBFAuthor Commented:
I have further information that is promising but I still cannot figure out the issue.

If I use a fresh AD account with no existing profile on the PC and attempt to launch Outlook it automatically creates the profile propery by connecting to exchange and it sets cached exchange mode to disabled.

HOWEVER, If i then go and delete the profile so that there are no mail profiles and try to launch Outlook again it does NOT autoconnect to the exchange server and create the profile. It gets hung up and displays the following string in the exchange server connection box:  /O=xxxxxx xx/OU=MIL/cn=Configuration/cn=Servers/cn=xxx-xxxx   I need to manually clear that out and type in the name of the exchange server and then click ok and it will connect and create the profile. This time however the profile is created with cached exchange mode turned ON.

So it appears my two issues are related.  If a user is able to automatically create a profile without any issues then cached exchange mode is turned off.  However if the user needs a 2nd profile for a different account or we need to delete the profile for some reason it won't automatically generate a new profile.

Something appears to be left in the users profile after creating an outlook profile even after deleting it that prevents further successful automatic exchange profile creations.
0
 
GWMerrellCommented:
Copy your MSP file and remove the Configure an Exchange Server Connection for new or existing profiles" portion of the Admin setup for the MSP.
Don't specify exchange server settings, Add accounts, Remove Account and export settings, specify send/ receive groups.
Then test your MSP with " use existing profile" settings.
 
*** If I recall correctly, this was an issue with the tool and when creating the profile, it would automatically put the profile into cachemode.
 
0
 
NBFAuthor Commented:
Thank you for the suggestion.  I will let you know my testing results this afternoon.
0
 
NBFAuthor Commented:
Thats actually no good.  If I do that then new users would have to manually create a profile for themself.  That exchange configuration section is very important for that functionality.
0
 
GWMerrellCommented:
If you are running Exchange 2007, it will auto create it. If you are running exchange 2003, it will prompt to auto create it with two clicks.
Wdat is your configuration and have you tried it yet?
If you are 03, I can probably provide you with some reg keys or ADM files you can GPO outlook into Online mode and not cache mode.
 
0
 
NBFAuthor Commented:
We have 2003 Exchange.  We will be moving to 07 later this year.  its not a huge problem just an annoyance at this point that will probably go away with the implementation of exchange 07 and autodiscover.

I am about to test your suggestion with a modified .msp.
0
 
GWMerrellCommented:
OK - let me know if you need more tricks to work around 2003.
0
 
NBFAuthor Commented:
I did as you suggested and completely disabled the settings for profiles and exchange.  I fully removed office and reinstalled using the .msp.

Same behavior.
The first time a profile is created automatically it finds the exchange server and connects automatically and leaves cached mode off.  If I then delete the mail profile and open outlook again it gets stuck trying to communicate with the exchange server to create a profile.  If I clear out the string in the connection box and just type in the name of the exchange server it works but it still sets up the profile with caching turned on.

Cached exchange mode is still being turned on by default when creating a new profile after one has already been created even if you delete it.  Using MAIL in control panel produces the same behavior.

Stumped again...

I am seeing the same behavior on both vista and xp with office 2007.  Its like running the new .MSP does not make the configuration changes even though the event log says it runs successfully.  Even a new fresh installation has the same behavior...
0
 
GWMerrellCommented:
If you tried that on a clean machine and still being placed in cachemode, I would suggest you go with tattoo'n the registry to force Online mode via adding the reg keys in the MSP or even a GPO to do the same action.
Are you comfortable with this action?
0
 
NBFAuthor Commented:
Will it turn cache mode off for all profiles of all users currently on the machine?

What is the reg key I need to change/add?  I am comfortable applying it via the .msp(if that even works, kind of disappointed right now) or GPOs.
0
 
GWMerrellCommented:
Let me gather those for you, in the meantime, I would suggest this autodiscovery configuration while you remain under Exchange 2003:
 
ADM settings for a GPO:
 

CATEGORY "[HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\AutoDiscover"
KEYNAME "Software\Microsoft\Office\12.0\Outlook\AutoDiscover"
 POLICY "ZeroConfigExchange"
  PART "ZeroConfigExchange"
  NUMERIC
  VALUENAME "ZeroConfigExchange"
  END PART
 END POLICY
END CATEGORY
 
 
0
 
GWMerrellCommented:
0
 
NBFAuthor Commented:
GW do you have a way to reverse that GPO that disables autodiscovery for when we do move to exchange 07?
0
 
GWMerrellCommented:
All you need to do is just change the value when you move to Ex07
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 9
  • 8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now