?
Solved

Link agregation / etherchannel between Nortel switch and Cisco 4507

Posted on 2009-04-28
2
Medium Priority
?
2,676 Views
Last Modified: 2012-06-27
Hello everyone,

I am trying to configure our nortel switch module in an IBM blade to bond two 1 GB uplinks into a single trunk line using port aggregation to a cisco 4507. The configuration works fine with one link connected once I connect the second link after about 5 minutes i start to see packet loss and then eventually total loss of connectivity. It seems it is causing a loop in switch that spanning tree is not catching.

Our network is pretty flat with only one data vlan using vlan 1

Config on nortel
On the nortel side through the GUI i have created a trunk group and added ports EXT 1 and EXT2.

Cisco config
On the cisco side here is the configuration
interface Port-channel2
description uplink SFBNORTELSW02
switchport
switchport trunk encapsulation dot1q
switchport mode trunk

interface GigabitEthernet3/7
description Uplink to SFBNORTELSW02
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode on
!
interface GigabitEthernet3/8
description Uplink to SFBNORTELSW02
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode on

Any help would be greatly appreciated.

0
Comment
Question by:jdflory
2 Comments
 
LVL 13

Expert Comment

by:Quori
ID: 24256314
Have you configured STP PVST on the Cisco side? Not using any link aggregation protocols on the server side of things?
0
 

Accepted Solution

by:
jdflory earned 0 total points
ID: 24256634
Thanks for the response.  I just figured it out.

The GUI on the nortel switch said that the trunk group was enabled but after logging into the cli i ran

/info/l2/trunk 1 and it said disabled.  Once i enabled it worked as it was supposed to.

My only guess is was not using the trunk group at all but was using DTP to trunk to the cisco and when connected the second link it created a loop.  I still not sure why spanning tree did not catch the loop.

Spanning-tree is configured and the switch that i was uplinking to was configured as the root bridge.

Kind of weird....but it is working now.

Thanks for responding
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question