Lotus Notes Replication - Have to clear replication history

Posted on 2009-04-28
Last Modified: 2013-12-18
I am using Lotus Notes 7.0.2 and am replicating with a Domino server. Every once in a while someone will send me an Email but when I replicate the Email does not show up. My Notes Admin told me to clear the Replication History and then replicate again. This always solves the problem, but I end up with additional documents in my Inbox which I had previously deleted. Is there a configuration problem somewhere that causes this behavior?
Question by:Sandman2
    LVL 46

    Accepted Solution

    Several possibilities, here are some:
    - your replication settings are wrong, e.g. the local replica replicates with the wrong server, or the schedule is wrong, or something like that
    - you have multiple replicas of the same database on your local system, or maybe even on the server
    - you have replicas on multiple servers, and these servers do not replicate that particular database
    - the server(s) do(es) not have sufficient rights to modify the database (inlikely)
    - there is some replication formula that somehow acts weird (unlikely)
    - the cutoff time for replication stubs is set very low, maybe even too low (Remove documents not modified in the last X days)

    What are the replication settings, how often is it done, where are the replicas, and what is X?

    Author Closing Comment

    I sent your response to our Notes Admin and he was able to immediately diagnose the problem with my setup and fix the problem.
    LVL 46

    Expert Comment

    by:Sjef Bosman
    That's a comment I like :-))

    Thanks for the grade!
    LVL 22

    Expert Comment

    Dang, I was waiting to see what the fix was!

    Author Comment

    The problem was that in the Replication Settings for the DB, I had "Any Available, try last successful first". We happen to have 2 Domino servers and what would happen is that I would replicate with one server one time, and then the other server another time. This created confusion with the replication engine.

    I changed the preferred server to the correct one and then cleared the Replication History before performing another replication. I then did this for all DB's with which I replicate.

    Hope that clarifies the solution a little.
    LVL 22

    Expert Comment

    Thanks, Sandman

    Featured Post

    IT, Stop Being Called Into Every Meeting

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    Join & Write a Comment

    You’ve got a lotus Domino web server, and you have been told that “leverage browser caching” is a must do. This means that we have to tell the browser everywhere in the web to use cache. In other words, we set (and send) an expiration date in the HT…
    IBM Notes offer Encryption feature using which the user can secure its NSF emails or entire database easily. In this section we will discuss about the process to Encrypt Incoming and Outgoing Mails in depth.
    In this sixth video of the Xpdf series, we discuss and demonstrate the PDFtoPNG utility, which converts a multi-page PDF file to separate color, grayscale, or monochrome PNG files, creating one PNG file for each page in the PDF. It does this via a c…
    This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…

    734 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    23 Experts available now in Live!

    Get 1:1 Help Now