[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 678
  • Last Modified:

TCP/IP Protocol driver not installed

Hi,
I have a windows xp media center computer that cannot send or receive anything through the network adapter.  I can see that in device manager, show  hidden devices, that  the TCP/IP Protocol driver is not installed.  I cannot access web or anything requiring network connectivity.  How can I get this driver installed?

Thanks,
John
0
calavera44
Asked:
calavera44
1 Solution
 
akahanCommented:
When you go to Control Panel - Network Connections and right-click on your network adapter (probably called Local Area Connection), and click Properties, and look in the window labeled "This connection uses the following items," and scroll down in that window, is one of the listed items "Internet Protocol TCP/IP" ?

0
 
jcimarronCommented:
0
 
MereteCommented:
Make sure you have correctly set up your lan network.
Whose on there how many others?
How do you connect to the internet ?
how do you access others files?
All xp home or pro?
you'll need
network adapter
Router
100 Mbps ethernet cable from your computer to the router port 1 or 2 etc
you have given yourself yourself a unique name in the MSHOME or WORKGROUP and are all  members of the same workgroup name>>r/click my computer properties computer name> computer description eg> John
Workgroup > workgroup apply reboot
you have checked windows firewall is set to allow networking in the exceptions tab
you have shared a folder.
Do you have any other firewalls, in zone alarm you need to add a unique ip address for each of you on the  lan  it can be something like 192.168.2 or 192.168.1.3  host name John
maybe the firewall blocking you
log onto the router
open a web page type in 192.168.1.1 press enter
then type admin
password
admin pres enter
otherwise try the windows help and support at start menue select fixing a problem > networking and run the automated tests and diagnostics for networking.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
calavera44Author Commented:
Hi Merete,

I found out what the issue was causing all these problems.  I ran combofix, it found that there was a rootkit installed which it was able to remove.  I then installed Malware Bytes anti malware and ran that.  It found 7 other pernicious virus and spyware which it was able to remove.  I rebooted and now I can browse the web.

I downloaded and installed CleanUp!  I also ran Dial a Fix.  The adapters appear in task manager and the network connection is ok now as well.

Thanks for your input.  All the issue had to do with the rootkit.

John Allen
0
 
calavera44Author Commented:
Hi to the moderator,

As you can see I found the solution myself.  I think it is a valuable answer to have in the EE database.  Can you keep the question and answer but not award the points?

Let me know,
John Allen
0
 
MereteCommented:
John  that's great. If you have a question about what to do now please use the request attention in your first question at the bottom right
Fill it in and then wait till a moderator assists you.
Regards Merete
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now