[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 590
  • Last Modified:

Cisco 837 Router dsl connection problem

I'm having trouble with my router establishing a dsl connection.

It just doesnt seem to connect. Hopefully it's something simple.

I used the easy web interface to create the connection so I assume it shoudl work ut it does not.

Extremely urgent if you can help.

thanks
sean

dsl status looks good 
 
Modem Status:    Showtime (DMTDSL_SHOWTIME)
DSL Mode:        ITU G.992.1 (G.DMT)
ITU STD NUM:     0x01                            0x01
Vendor ID:       'ALCB'                          'P   '
Vendor Specific: 0x0000                          0x0000
Vendor Country:  0x00                            0xB5
Capacity Used:   30%                             36%
Noise Margin:    26.5 dB                         25.0 dB
Output Power:    20.0 dBm                        11.5 dBm
Attenuation:     40.5 dB                         22.0 dB
Defect Status:   None                            None
Last Fail Code:  None
Selftest Result: 0x00
Subfunction:     0x15
Interrupts:      646 (1 spurious)
Activations:     1
Init FW:         embedded
Operartion FW:   embedded
SW Version:      3.9.220
FW Version:      0x1A04
 
                 Interleave             Fast    Interleave              Fast
 --More--
Speed (kbps):             0             2272             0               288
Reed-Solomon EC:          0                0             0                 0
CRC Errors:               0                0             0                 0
Header Errors:            0                0             0                 0
Bit Errors:               0                0
BER Valid sec:            0                0
BER Invalid sec:          0                0
 
LOM Monitoring : Disabled
 
DMT Bits Per Bin
00: 0 0 0 0 0 0 0 0 0 2 4 5 6 6 6 5
10: 5 5 5 6 6 6 5 5 5 4 3 2 2 2 0 0
20: 0 0 0 0 0 0 0 0 2 2 2 3 4 4 4 4
30: 4 4 4 4 4 4 4 5 5 4 5 5 5 5 5 5
40: 0 5 5 5 5 5 5 5 5 5 5 5 5 5 5 5
50: 5 5 6 5 6 6 6 6 6 2 6 6 6 6 6 6
60: 6 6 6 5 6 6 6 6 6 6 6 6 6 5 5 5
70: 5 5 4 5 5 5 5 5 5 5 5 5 5 5 5 4
80: 4 4 5 4 4 4 4 5 4 4 4 4 4 4 4 4
90: 4 4 2 4 4 4 4 4 4 4 4 4 3 3 3 2
B0: 2 0 0 2 2 2 2 2 2 2 2 2 0 2 2 2
C0: 2 2 0 2 2 2 2 0 0 0 0 0 2 2 2 0
D0: 2 0 0 0 0 2 2 2 2 0 2 2 2 2 2 0
E0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
F0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
 
- - - - - - 
 
 
Running COnfig 
 
Current configuration : 3142 bytes
!
version 12.3
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname ttrouter
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200 debugging
logging console critical
enable secret 5 $1$MF0Q$JzlGdgu/B01lpENlv0.0w0
clock timezone PCTime 0
clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
no aaa new-model
ip subnet-zero
no ip source-route
ip dhcp excluded-address 19.168.0.1 19.168.0.210
ip dhcp excluded-address 192.168.0.150
!
ip dhcp pool sdm-pool1
   import all
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.150
!
!
ip tcp synwait-time 10
ip cef
ip domain name tottontimber.com
no ip bootp server
ip ips po max-events 100
ip ssh time-out 60
ip ssh authentication-retries 2
no ftp-server write-enable
!
!
username sean privilege 15 secret 5 $1$NRCb$aCkUo1KWi84MPHfo.Ca/S.
!
!
no crypto isakmp ccm
!
!
!
interface Ethernet0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-Ethernet 10/100$$ES_LAN$$FW_INS$
 ip address 192.168.0.150 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
 no cdp enable
 hold-queue 100 out
!
interface ATM0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 description $FW_OUTSIDE$$ES_WAN$
 ip nat outside
 ip virtual-reassembly
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface FastEthernet1
 duplex auto
 speed auto
!
interface FastEthernet2
 duplex auto
 speed auto
!
interface FastEthernet3
 duplex auto
 speed auto
!
interface FastEthernet4
 duplex auto
 speed auto
!
interface Dialer0
 description $FW_OUTSIDE$
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 encapsulation ppp
 ip route-cache flow
 dialer pool 1
 dialer-group 1
 ppp authentication chap pap callin
 ppp chap hostname xxxxxxxx@xxxxxxxx
 ppp chap password 7 xxxxxxxxxxxxxxxxxxxxx
 ppp pap sent-username xxxxxxxxx@xxxxxxxxx password 7 xxxxxxxxxxxxxxxxxx
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 1 interface ATM0.1 overload
!
logging trap debugging
access-list 1 remark INSIDE_IF=Ethernet0
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 19.168.0.0 0.0.0.255
dialer-list 1 protocol ip permit
no cdp run
!
control-plane
!
banner login ^CAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
 login local
 no modem enable
 transport output telnet
line aux 0
 login local
 transport output telnet
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
scheduler interval 500
end

Open in new window

0
seancaddell
Asked:
seancaddell
  • 2
  • 2
1 Solution
 
QuoriCommented:
The Dialer interface should be set to "ip address negotiated" for a start.

Could be authentication. From command line, turn on some debugging

debug ppp authentication

If telnet'd in, then do:

term mon

Watch it for a bit then turn off debugging.

un all


Move "ip nat outside" to be on the Dialer interface.

Change:
ip nat inside source list 1 interface ATM0.1 overload
Replace ATM0.1 with Dialer0
0
 
seancaddellAuthor Commented:
I think this might be a dns issue.

The adsl interface logs in correctly. But I have no internet connection, when I test the connection in SDM it gives a dns error.

How do I tell the router to get its DNS data from the connection?
0
 
seancaddellAuthor Commented:
I reset the router and have only amended a few settings.

heres the new config

Current configuration : 1977 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 $1$AlJ9$vBWOZWoq9udM7HyYzCJjP.
!
clock timezone PCTime 0
clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
no aaa new-model
ip subnet-zero
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool sdm-pool1
   import all
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1
   dns-server 10.10.10.1
!
!
ip domain name yourdomain.com
ip ips po max-events 100
no ftp-server write-enable
!
!
username xxx privilege 15 secret 5 $1$rXAK$cxa0GJc1PS4ocEDPURn/7.
!
!
no crypto isakmp ccm
!
!
!
interface Ethernet0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-Ethernet 10/100$$ES_LAN$
 ip address 10.10.10.1 255.255.255.0
 ip virtual-reassembly
 hold-queue 100 out
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface FastEthernet1
 duplex auto
 speed auto
!
interface FastEthernet2
 duplex auto
 speed auto
!
interface FastEthernet3
 duplex auto
 speed auto
!
interface FastEthernet4
 duplex auto
 speed auto
!
interface Dialer1
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 ppp chap hostname xxxxxxxxxxxx@xxxxxxxxxxxxxxxxxx
 ppp chap password 0 xxxxxxxxx
 ppp pap sent-username xxxxxxxxxxxxx@xxxxxxxxxxxxxx password 0 xxxxxx
!
ip classless
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
!
control-plane
!
banner login ^CAuthorized access only!
 Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
 login local
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
end
0
 
QuoriCommented:
ip domain-lookup
ip name-server <ISP DNS Server #1>
ip name-server <ISP DNS Server #2>
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now