Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 751
  • Last Modified:

Samba with wins support not able to connect from winxp clients

I have a samba server running and configured. I can login to the local shares but none of my windows clients can see my linux shares. I have setup wins on samba and one of my xp clients is pointing to the wins server on 192.168.1.90 (advanced tcp settings in windows). I also enabled "netbios over tcp" under the advanced settings.

All I need to do at this point is get my windows computers to see the linux shares.

Thank you for any help on this!
smb.conf file:
 
[global]
        log file = /var/log/samba/log.%m
        guest account = nobody
        socket options = TCP_NODELAY
        encrypt passwords = yes
        passdb backend = tdbsam
        allow hosts = 127. 192.168.1.
        interfaces = lo, eth0
        wins support = true
        name resolve order = wins lmhosts hosts bcast
        dns proxy = no
;       cups options = raw
        netbios name = linux01
        writeable = yes
        wide links = no
        delete readonly = yes
        default = global
        workgroup = linuxgroup
        os level = 65
        invalid users = root
        security = share
;       create mode = 755
        max log size = 50
;       revalidate = yes
;       client lanman auth = yes
;       lanman auth = yes
        domain master = yes
        smb ports = 139
 
[share]
        comment = No Comment
        path = /share
        writable = yes
        browsable = yes
        available = yes
        guest ok = yes
 
[filestor002]
        comment = No comment
        path = /filestor002/share
        writable = yes
        browsable = yes
        available = yes
        guest ok = yes

Open in new window

0
dr34m3rs
Asked:
dr34m3rs
  • 3
  • 3
1 Solution
 
Morne LateganCommented:
Have you tried to connect to:

\\192.168.1.90

You can type it into start->Run
0
 
dr34m3rsAuthor Commented:
It worked but...  I can't create files? It says "unable to create the file 'new text document.txt' - access is denied...  

I have writable = yes in my smb.conf file. Where should I look? My permissions are root:root 755 for the share directories...  should they be 777?

Thank you very much for all your help.
0
 
Morne LateganCommented:
Make it

root:nobody 770

That would allow the guest account (nobody) to write to it.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
dr34m3rsAuthor Commented:
Wow, it is finally working!! Thank you so much for all your help! I have learned a LOT from this.
0
 
dr34m3rsAuthor Commented:
Yaaay!!
0
 
Morne LateganCommented:
You're welcome :)
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now