I can't get a Microsoft VPN to work with a Cisco PIX 501

I want to use my Microsoft 2003 server to do a VPN.  What do I need to do to my PIX 501 firewall to make this happen?
Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 47
fixup protocol pptp 1701
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside_access_in permit tcp any host 192.168.199.2 eq 808 
access-list outside_access_in permit tcp any host 192.168.199.2 eq smtp 
access-list outside_access_in permit tcp any host 192.168.199.2 eq https 
access-list outside_access_in permit tcp any host 192.168.1.9 eq smtp 
access-list inside_outbound_nat0_acl permit ip any 192.168.1.208 255.255.255.240 
pager lines 24
logging on
logging timestamp
logging buffered debugging
mtu outside 1500
mtu inside 1500
ip address outside 192.168.199.2 255.255.255.0
ip address inside 192.168.1.2 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool HAVPN 192.168.1.210-192.168.1.220
pdm location 192.168.1.9 255.255.255.255 inside
pdm location 192.168.199.2 255.255.255.255 outside
pdm location 192.168.1.208 255.255.255.240 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp 192.168.199.2 smtp 192.168.1.9 smtp netmask 255.255.255.255 0 0 
static (inside,outside) tcp 192.168.199.2 https 192.168.1.9 https netmask 255.255.255.255 0 0 
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.199.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+ 
aaa-server TACACS+ max-failed-attempts 3 
aaa-server TACACS+ deadtime 10 
aaa-server RADIUS protocol radius 
aaa-server RADIUS max-failed-attempts 3 
aaa-server RADIUS deadtime 10 
aaa-server LOCAL protocol local 
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
sysopt connection permit-l2tp
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.3-192.168.1.34 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:577a8e1a2a39beae2977c51fa6516c3f
: end
[OK

Open in new window

tjmustangAsked:
Who is Participating?
 
nodiscoConnect With a Mentor Commented:
hey there
Sorry - that won't work.  for the PPTP server to work from outside, you need a direct 1:1 static - you cannot port redirect.  The reason is that port redirection only works for tcp and udp and pptp needs gre to work.
The solution would be:
Remove existing statics
Use a free outside ip address e.g. x.x.x.x

static (inside,outside) x.x.x.x 192.168.1.9 netmask 255.255.255.255
clear xlate

Then:
access-list outside_access_in permit tcp any host x.x.x.x eq 808
access-list outside_access_in permit tcp any host x.x.x.x eq smtp
access-list outside_access_in permit tcp any host x.x.x.x eq https
access-list outside_access_in permit gre any host x.x.x.x
access-list outside_access_in permit tcp any host x.x.x.x eq pptp

access-group outside_access_in in interface outside

hth
0
 
nodiscoCommented:
Gre is not supported over Port address translation so you need to do a 1:1 static for your VPN server:

e.g.
Where 2.2.2.2 is a free public ip:

access-list outside_access_in permit tcp any host 2.2.2.2 eq pptp
access-list outside_access_in permit gre any host 2.2.2.2

static (inside,outside) 2.2.2.2 192.168.1.15 netmask 255.255.255.255

Note - if your pptp server is also your smtp server (192.168.1.9) then you need to remove all existing statics and just replace with the above line.  Your outside_access_in will still only allow access directly in, but as mentioned you cannot allow pptp traffic in over port redirected addresses.

hth

0
 
tjmustangAuthor Commented:
So my PPtP server is also my SMTP server....so.....I need to only issue the following commands

access-list outside_access_in permit tcp any host 192.168.199.2 eq pptp
access-list outside_access_in permit gre any host 192.168.199.2

192,168.199.2 is he the outside PIX IP that talks to our static IP
0
All Courses

From novice to tech pro — start learning today.