• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 200
  • Last Modified:

Spammers sending directly to my server instead of going to anti spam server

Hi guys.

I have subscribed to message labs anti spam service.

messagelabs server mx 10
my server                 mx 20

Normally by default, email will be routed to the message labs server and scanned for spam before sending to our server.

However, some messages are not scanned by the anti spam and sent directly the inbox.

I checked and found that the spammers are sending direct to the server.

Does anyone know what i can do to make sure they send email to my anti spam without sending to my server?

Do I need only one mx record (message lab) and exclude other server record?
I am using exchange 2007 and server 2003.

Thanks
0
moneywell
Asked:
moneywell
  • 2
1 Solution
 
Steven WellsCommented:
You may like to remove your MX record entirely. I guess the spam systems will try all mx records listed as possible hosts.
0
 
moneywellAuthor Commented:
so i leave only message labs mx record only?
the others i leave it as it is?
0
 
Steven WellsCommented:
Yeah, just remove your MX record of 20, leave all other settings alone. This means that the mesasge labs host is the only one that will be seen. I would try that.  It just means that if someone tries to send an email to message labs and they are down, it will fail. But i guess that would be pretty rare.
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now