Quickbooks 2009 Premier Crashes on Load

Posted on 2009-04-28
Last Modified: 2012-05-06

I am running Vista.  I have Quickbooks 2009 Premier - Accountant Edition installed on my laptop.  Quickbooks was open when the battery fell out of my Dell laptop (blasted Dell...).  Obviously, the computer went off immediately without a graceful shutdown.  After turning it back on, Quickbooks fails to load.  It gets most of the way through the load process and then crashes with a completely uninformative error message:   "Quickbooks has stopped working."  It happens every time I attempt to load Quickbooks.  It also happens when I run Windows in safe mode and attempt to load Quickbooks.

This has happened to me before several months ago when the same scenario happened: Quickbooks was open when the battery fell out.  I tried Repairing the installation, and uninstalling / reinstalling (including deleting the entire Program Files/Quickbooks folder).  Neither fixed the problem.  I was only able to fix it by formatting and reinstalling Windows and then reinstalling Quickbooks.  I'd rather not do that again.

I'm fairly confident it is not an issue with the company data file, because the same crash occurs regardless of which company file I try to open, as well as when I hold the Ctrl key during load to prevent it from loading a company file.  Perhaps it's corrupted registry entries?  Perhaps it's corrupted files that typically get left behind from an uninstall?

I'd appreciate any assistance.  Thank you.
Question by:Orcadian

    Accepted Solution

    I was able to resolve this myself. I did two things, and I'm not sure which one fixed it, but doing both worked.

    1. I've heard all the talk about deleting the user account for various issues. I didn't want to delete my user account, but I went digging around. I found the C:\Users\\AppData\Local\Intuit\ folder. I deleted the folder, and all the sub-folders. It has two sub-folders, one is a log file (which may be useful for debugging, so I saved a copy of it) and the other is the QBWUSER.INI. I think the QBWUSER.INI file was probably all I needed to delete, but I'm just guessing here.

    After deleteing the above files, I was able to open Quickbooks without it crashing, but it would crash as soon as I loaded a company file.

    2. I noticed that my QBW files had next to my company file (MyCompany.QBW) there were also two files (MyCompany.QBW.ND and MyCompany.QBW.TLG). I figure these are temporary / data locking files for multi-user stuff, but I'm not sure. Regardless, I deleted both of these files, leaving the MyCompany.QBW file.

    After doing these two things, I noticed some very strange behavior (Windows Explorer crashing multiple times, etc.) I rebooted Windows, loaded Quickbooks, and everything works great!

    I hope this helps someone else solve the problem!

    Expert Comment

    I'd just like to add 2nd support to this!
    Similar issue - Vista on Toshiba Portege M800 - QB 2009 Premier Accountants Edition.
    Go anywhere near this particular qbw company file and explorer would crash.

    I Googled and got the above solution suggestion. Before looking at the additional files, I first enabled the default administrator login in Vista and logged on as administrator (the user with the crashing issue was also admin level user). I was able to open the company that was previously crashing > verify it > rebuid it > backup it up to a few locations to be safe and all was OK. Phew!

    I then logged back on as the user with the original issue > opened the company from the 'new' location and all was fine - but - I wanted to put the company back to it's 'normal' location and bang! crashing again. Checked folder properties / permissions, etc and all was ok. Folder options and show protected and then deleted the other two files that accompany the qbw file as originally suggested above.
    Reopen the company from the 'normal' location and everything was ok > verify > backup > close company and check the 'normal' location again and the two additional files had been recreated.
    Open company 'as normal' from 'normal' location and everything is in order.

    So what came first, the chicken or the egg? My hunch is it's the two additional files that are locked or corrupt in some way, so perhaps you could delete these somehow without the 'other user' element. Perhaps delete them via command prompt if necessary? Either way I'm not about to reinvent again.

    The originial post helped me and I hope this slight refinement & confirmation will help you too come your time.


    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    IT, Stop Being Called Into Every Meeting

    Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

    There are many reasons a PC runs slower than when it was new, ranging from malicious software intended to mess things up to simple general Windows use.  Your PC performance may slowly degrade over time without you noticing but when you buy a PC from…
    You may need to view past transactions from previous QuickBooks files or other QuickBooks company files when:       1. you are working in another QuickBooks file       2. QuickBooks is closed QuickBooks users who would benefit from this artic…
    The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
    This video discusses moving either the default database or any database to a new volume.

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    14 Experts available now in Live!

    Get 1:1 Help Now