Insufficient Permissions on crm 4.0

Just installed CRM 4.0 (not live yet). Although I can get in OK none of the users can. I have admin permissions to the server and database and they don't so this could be the problem but I am unsure where to start looking.
InsufficientPermissions.gif
dontelimpikeAsked:
Who is Participating?
 
stacko111Commented:
So this is a custom security role then. I actually had the same problem and managed to solve it but unfortunately I'm not sure what solved it.

There are two things you could try:

1. Give the affected users the administration role, publish then remove it again. I think there is a little bug with custom security roles, giving them a system one could fix it. If it doesn't work try...
2. In the affected role configuration, find the Business Management tab find User configuration, enable Create, Read & Write at least at the user level.

I got mine to work eventually - actually one other thing that I tried was recreating the user - I would only recommend trying that as a last resort though.

Hope this helps
0
 
stacko111Commented:
When you create users in CRM you also need to assign them Security Roles.

Go to Settings > Administration > Users > Highlight the User > Click on the More Actions menu > Select Manage Roles > Select the relevant Security Roles.

This should solve the problem.
0
 
dontelimpikeAuthor Commented:
The users are a member of a created role called HBC Standard User.  I have taken myself out of the administrator role and put myself into the HBC Standard User role but it still works for me and not for the users
0
 
dontelimpikeAuthor Commented:
That worked fine - thanks very much
0
 
dontelimpikeAuthor Commented:
Gave the role admin permissions and then took them away. It worked.  Like you say, it seems to be a little bug in SQL server.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.