Can't access OWA Externally

Hello all.  Here is the situation.  Everything worked fine until Comcast replaced our modem, so I think it has something to do with that, but not sure.  We have three servers each with local IPs of 10.0.0.2, 10.0.0.3, and 10.0.0.5.  Exchange server is on the 10.0.0.2 server.  Internally, I can type 127.0.0.1/exchange and get it to work, but when I type in our Static IP, Google comes back with a broken link error.  the funny thing is with the old modem, if i just typed in our static IP by itself externally, it couldn't find anything, but now I get the login of the modem.

Comcast keeps wanting me to change the modem IP settings, but when I do, the only way to get to the internet is to change the IPs on my servers, which worked fine before as the 10.0.0.*.  So, I still think there is something in the modem that is needing configuration.  Comcast mentioned something about passthrough, and tried that, but to no prevail.  I tried port forwarding port 80 and 443 even though we don't have a certificate to the exchange server, and nada.  

I hope this makes sense.

Mike
tmss_it_deptAsked:
Who is Participating?
 
Steven WellsConnect With a Mentor Systems AdministratorCommented:
Hi,

The problem is most likely to do with port forwarding rules on your modem/router.

You need to port forwared port 80 to your exchange server IP address. So when you open a broswer and enter your external IP address it should port forward to your exchange page. You should really put a certificate on your exchange server (self signed will do using iis6 reskit) if you are using exchange 2003.

It's most likely the modem has reserved port 80 for external management. That may need to be changed to internal admin only depending on make/model of modem

Hope this helps.
0
 
tmss_it_deptAuthor Commented:
Is the self signed certificate free?  As for the port forwarding, that is kind of what I am thinking, just a little hard testing from within the network...  :)  I will check once i get out of the office.
0
 
Steven WellsSystems AdministratorCommented:
The self cert is free. You can download it as part of it iis res kit.

I found this site that explains how to do it.
http://www.somacon.com/p42.php

You may need to adjust for your server. Then you can assign that certificate to the exchange directory in iis.
0
 
tmss_it_deptAuthor Commented:
Cool, thanks.  I will let you know about the other later.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.