When using a L2TP vpn how do you setup windows xp to use that dns as the default one

We are using SmoothWall UTM-308 as the L2TP vpn gateway. It pulls the proper ip and updates the dns server.

The client a windows xp sp3 machine using the built in vpn client from microsoft. We have setup manual dns and wins ips in the connection.

When I use nslookup it pulls the dns server from the network connection a 192.168.1.* and not the vpn connections 10.*.*.*, since we are using two dns servers (internal and external) for the domain it is not pulling the right ips. It is using the lan dns to query the dns and it returns a external ip, and not the internal dns on the vpn connection.
travispalmAsked:
Who is Participating?
 
travispalmAuthor Commented:
We have switched the vpn over to a SSL VPN. With it the vpn's dns takes prioritie.

Thanks for all the help
0
 
arnoldCommented:
if you run ipconfig /all do you see the VPN based DNS servers reflected under the VPN IP configuration?
0
 
arnoldCommented:
Do you push from the server the LAN DNS settings to the client?
Check the properties of the L2TP connection on the client system.  Network/tcp_ip properties.  What do you have setup there (obtain IP and DNS) or do you have them manually set?
0
On-Demand: Securing Your Wi-Fi for Summer Travel

Traveling this summer?Check out our on-demand webinar to learn about the importance of Wi-Fi security and 3 easy measures you can start taking immediately to protect your private data while using public Wi-Fi. Follow us today to learn more!

 
travispalmAuthor Commented:
Both DNS are setup under each connection, the lan and the vpn. The system uses the lan dns first so we are running into problems with it pulling the external ip address for the domain and not the internal ones that reside on the vpn dns. Thus some items do not work. Both networks pull ip via dhcp, but we have setup the vpn to use a static dns and wins.
0
 
arnoldCommented:
Oh, do you use something like domain.com?
usually if you use private naming convention domain.local domain.private.
The lookup fails over to the VPN DNS servers.  When using an externally accessible domain name, the LAN DNS servers provide the answer so there is no need to check with the VPN provided DNS.



The only remedy is to create a static mapping in c:\windows\system32\drivers\etc\hosts
IP hostname
0
 
travispalmAuthor Commented:
Yes we are using a FQDN for your domain, we have internal and external resources that need to be accessed and it was setup that way for convenience to the end user. We have worked on SSL VPN systems and when they are connected the dns server priority is set to use it first.

Our vpn users obtain an external dns ip from the lan/wireless card. This resolves our external resources. When the vpn in we need the system to use the vpn dns first and not the lan/wireless card. Since not all the dns info is on the external dns servers some request roll over to the vpn dns and are aswered correctly, others do not they pull the external dns.

Aside from manually switching the dns server ips in the lan/wireless card how can we set the priority of the dns servers to use the vpn first and the lan/wireless second like the ssl vpn seems to be able to do.
0
 
arnoldCommented:
The only way in this case is you setup the L2TP VPN connection to route all traffic through the VPN.
0
 
travispalmAuthor Commented:
We have tested both options, to route all traffic threw the vpn gateway and not. Both still result in the lan/wireless dns server being the first queried.
0
 
arnoldCommented:
Unfortunately, in this case there is little that can be done other than manually adding entries into the hosts file..
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.