Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2252
  • Last Modified:

SQL Restore Failing:Operating system error 1130(Not enough server storage is available to process this command.).

We have been experiencing an intermittent problem with the restore of a 50GB database to a SQL Server that runs under Windows 2003. The restore runs for 50 minutes or so, then dies with the following errors:

BackupMedium::ReportIoError: read failure on backup device '\\POSDBASE1\SQLBackups\Current\Autopart_Full.bak'.
Operating system error 1130(Not enough server storage is available to process this command.).

Internal I/O request 0x4372D888: Op: Read, pBuffer: 0x059D0000, Size: 65536, Position: 44023354880, UMS: Internal: 0x0, InternalHigh: 0xD197DC7C, Offset: 0x3FFF1600,
OffsetHigh: 0xA, m_buf: 0x059D0000, m_len: 65536, m_actualBytes: 0, m_errcode: 1130, BackupFile: \\POSDBASE1\SQLBackups\Current\Autopart_Full.bak

In the past, a reboot of POSDEVDB1 has cleared this up (for weeks at a time). Ive rebooted twice today and cannot get around this problem. I do not believe this is a SQL Server problem.

I can restore the SQL dump if I copy it locally. The problem seems to occur only when restoring over a newtork.

Any thoughts? Comments? Suggestions?
0
CiciO
Asked:
CiciO
  • 4
  • 3
1 Solution
 
arnoldCommented:
Does the server where you are restoring the data have the 50GB on the drive to which you are restoring?
During the restore configuration process, make sure to double check the location to which the data and log files are to be restored.  You might by accepting the default option are trying to restore the database in c:\program files\micorosoft SQL server\.... rather than on a different drive that you designated as the database data storage location.

Do you have an option to copy the backup file such that it will be local to the system where the database will be restored?  Eliminating network hickup/saturation.
0
 
CiciOAuthor Commented:
There is sufficient diskspace on the drive I am restoring to.

Last night we rebooted BOTH machines (the machine we are restoring to, and the machine where the SQL Backup is located), and the process worked. We are temporarily "out of the woods" (till the next time).

Still, I don't know what was "wrong". Why do I intermittently receive the "...1130(Not enough server storage is available to process this command.)..." error in the first place?
0
 
arnoldCommented:
Next time, could you transfer the backup file to the system where the restore is taking place?
Is log shipping setup an option?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
CiciOAuthor Commented:
I have had this happen on two machines (one is a development box, the other is used for reporting).
The development box does not have sufficient diskspace for both the backup file and the database.
The reporting machine does. I did copy the backup file to the reporting machine and was able to restore it.

Log shipping is not an option.

Again, I believe this is an OS issue. "...1130(Not enough server storage is available to process this command.)..."  seems to be a generic error.  If we can find out what causes it, we should be able to resolve it.
0
 
arnoldCommented:
A hickup in network traffic might be the issue.
Did you try restoring from a mapped drive rather than a UNC path?
Is there an anti-virus program running?

In raw terms how much space do the data and log files take on the system where it is backed up?  Do they total 50GB or is the data file 40GB and the log file 30GB?
How much space do you have on the system where you are restoring?
Note: even though the backup file is 50GB of data, the restore process restores the files to the same size they are on the system.
0
 
CiciOAuthor Commented:
My network guys tell me there were no network hiccups.

I have NOT tried to restore from a mapped drive. I will try it next time it happens. Good suggestion.

Norton Anti-Virus is running. I disabled it and still had the problem.

The database takes up 54 GB, the log 7 GB.

After the succesfull restore, there is 13 GB free.
0
 
CiciOAuthor Commented:
I never really got a solution. Noone else responded. Decided to close the issue.
0
 
CITHelpdeskCommented:
Seen this before on some servers when copying large files across the network.. solution below..

http://support.microsoft.com/kb/285089

Regards
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now