[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

ASA 5505 VPN Issue - No matching SA, dropping

Posted on 2009-04-29
7
Medium Priority
?
49,634 Views
Last Modified: 2012-06-27
hello, i have installed an asa 5505 in a remote location (10.3.3.0). its working fine with vpn with main site(10.0.0.0), but not from another external location(10.1.1.0) . I can VPN from the location (10.3.3.0) the ASA is located to the  other remote site (10.1.1.0) but not from that remote site (10.1.1.0) back to the ASA site(10.3.3.0)

when i try i see in the log this message

 IP = 208.*.*.163, Received encrypted packet with no matching SA, dropping

AND

4      Apr 29 2009      13:43:45      713903                   IP = 208.*.*.163, Received Invalid Cookie message for non-existent SA
4      Apr 29 2009      13:43:44      113019                   Group = 208.*.*.163, Username = 208.*.*.163, IP = 208.*.*.163, Session disconnected. Session Type: IPSecLAN2LAN, Duration: 0h:00m:12s, Bytes xmt: 0, Bytes rcv: 0, Reason: crypto map policy not found

3      Apr 29 2009      13:43:44      713902                   Group = 208.*.*.163, IP = 208.49.79.163, Removing peer from correlator table failed, no match!

3      Apr 29 2009      13:43:44      713902                   Group = 208.*.*.163, IP = 208.49.79.163, QM FSM error (P2 struct &0x3c3dfe0, mess id 0x3834d1d2)!

3      Apr 29 2009      13:43:44      713061                   Group = 208.*.*.163, IP = 208.*.*.163, Rejecting IPSec tunnel: no matching crypto map entry for remote proxy 10.1.1.0/255.255.255.0/0/0 local proxy 10.3.3.0/255.255.255.0/0/0 on interface outside


usefull data to keep in mind:
main site info = 10.0.0.0  -   208.*.*242 <-- works fine
ASA location= 10.3.3.0   -   64.*.*.22  (can vpn to ext loc fine, cannot receive vpn from ext loc)
external loc  = 10.1.1.0   -   208.*.*.163  (accepts vpn from Asa loc, but doesnt vpn to it)

Here is the saved config

: Saved
:
ASA Version 7.2(3)
!
hostname ciscoasa
domain-name **
enable password u1N2uiTOMgtVzzpC encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.3.3.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 64.*.*.22 255.255.255.252
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name **
access-list outside_1_cryptomap extended permit ip host 64.*.*.22 host 208.*.*.242
access-list outside_1_cryptomap extended permit ip 10.3.3.0 255.255.255.0 host 208.*.*.242
access-list outside_1_cryptomap extended permit ip 10.3.3.0 255.255.255.0 10.0.0.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip 10.0.0.0 255.255.255.0 host 64.*.*.22
access-list outside_1_cryptomap extended permit ip 10.0.0.0 255.255.255.0 host 10.3.3.1
access-list outside_1_cryptomap extended permit ip host 64.*.*.22 host 208.*.*.163
access-list outside_1_cryptomap extended permit ip 10.3.3.0 255.255.255.0 host 208.*.*.163
access-list outside_1_cryptomap extended permit ip 10.3.3.0 255.255.255.0 10.1.1.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip 10.1.1.0 255.255.255.0 host 64.*.*.22
access-list outside_1_cryptomap extended permit ip 10.1.1.0 255.255.255.0 host 10.3.3.1
access-list outside_1_cryptomap extended permit ip host 208.*.*.163 host 64.*.*.22
access-list inside_nat0_outbound extended permit ip host 64.*.*.22 host 208.*.*.242
access-list inside_nat0_outbound extended permit ip 10.3.3.0 255.255.255.0 host 208.*.*.242
access-list inside_nat0_outbound extended permit ip 10.3.3.0 255.255.255.0 10.0.0.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip host 64.*.*.22 host 208.*.*.163
access-list inside_nat0_outbound extended permit ip 10.3.3.0 255.255.255.0 host 208.*.*.163
access-list inside_nat0_outbound extended permit ip 10.3.3.0 255.255.255.0 10.1.1.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 10.1.1.0 255.255.255.0 host 64.*.*.22
access-list inside_nat0_outbound extended permit ip 10.1.1.0 255.255.255.0 10.3.3.0 255.255.255.0
access-list rdp-capture extended permit tcp any interface outside eq 3389
access-list 100 extended permit ip 10.3.3.0 255.255.255.0 10.0.0.0 255.255.255.0
access-list 100 extended permit ip 10.3.3.0 255.255.255.0 10.1.1.0 255.255.255.0
access-list 100 extended permit ip 10.1.1.0 255.255.255.0 10.3.3.0 255.255.255.0
access-list outside_2_cryptomap extended permit ip host 64.*.*.22 host 208.*.*.163
access-list outside_20_cryptomap extended permit ip 10.1.1.0 255.255.255.0 10.3.3.0 255.255.255.0
access-list outside_20_cryptomap extended permit ip 10.3.3.0 255.255.255.0 10.1.1.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
no failover
monitor-interface inside
monitor-interface outside
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 64.*.*.21 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 208.*.*.163 255.255.255.255 outside
http 10.1.1.0 255.255.255.255 inside
http 10.0.0.0 255.255.255.255 inside
http 67.*.*.34 255.255.255.255 outside
http 208.*.*.242 255.255.255.255 outside
http 192.168.1.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set peer 208.*.*.242
crypto map outside_map 1 set transform-set ESP-DES-MD5
crypto map outside_map 2 match address outside_2_cryptomap
crypto map outside_map 2 set peer 208.*.*.163
crypto map outside_map 2 set transform-set ESP-DES-MD5
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption des
 hash md5
 group 1
 lifetime 86400
crypto isakmp nat-traversal  20
telnet timeout 5
ssh timeout 5
console timeout 0
management-access inside
dhcpd auto_config outside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
username admin password X4zeva05OugtPWs0 encrypted
tunnel-group 208.*.*.242 type ipsec-l2l
tunnel-group 208.*.*.242 ipsec-attributes
 pre-shared-key *
tunnel-group 208.*.*.163 type ipsec-l2l
tunnel-group 208.*.*.163 ipsec-attributes
 pre-shared-key *
prompt hostname context
Cryptochecksum:8a5486063a4eecb8bbad9f9a38bdc22c
: end
asdm image disk0:/asdm-523.bin
no asdm history enable



0
Comment
Question by:Comptx
7 Comments
 
LVL 5

Expert Comment

by:CoSmismgr
ID: 24265706
I don't know the ASA very well, but it appears to me you have no security-association statements

Try adding:

crypto map outside_map 65535 set security-association lifetime seconds 28800
crypto map outside_map 65535 set security-association lifetime kilobytes 4608000
crypto map inside_map 65535 set security-association lifetime seconds 28800
crypto map inside_map 65535 set security-association lifetime kilobytes 4608000

0
 

Author Comment

by:Comptx
ID: 24265830
Well, that didnt work. Thanks tho..

Anyon else have any idea?
0
 

Accepted Solution

by:
Comptx earned 0 total points
ID: 24272348
Fixed by JFrederick29.
Thanks
0
Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

 

Expert Comment

by:ntgtech
ID: 24453847
what was the fix.  I am getting the same thing in my asa
0
 

Expert Comment

by:sdbeezy
ID: 26210914
The fix would be nice to see - I am having a similar issue.
0
 

Expert Comment

by:mtanneryd
ID: 27665837
I'd very much like to know too. Have the same problem!
0
 

Author Comment

by:Comptx
ID: 27666789
To the rest of the people having the issue, the best way to fix it  is by deleting your VPN info from Connection Profiles under Site To Site VPN, then delete any rules that show on Crypto Maps under Advanced, also in Site to Site VPN area.

Then recreate the VPN using the wizard, and it should connect if you have all the right info.

You shouldnt need to add any rules manually using the CLI.

For some reason these ASA's can show you this error, but can be resolved by recreating the VPN. Ive had perfectly working ASA's throw me this error all of the sudden and i always get it back up by doing that.

Hope this helps.
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Concerto Cloud Services, a provider of fully managed private, public and hybrid cloud solutions, announced today it was named to the 20 Coolest Cloud Infrastructure Vendors Of The 2017 Cloud  (http://www.concertocloud.com/about/in-the-news/2017/02/0…
This past year has been one of great growth and performance for OnPage. We have added many features and integrations to the product, making 2016 an awesome year. We see these steps forward as the basis for future growth.
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…

831 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question