Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

PIX 506e VPN with route based NAT

Posted on 2009-04-29
2
Medium Priority
?
572 Views
Last Modified: 2012-05-06
I have a PIX 506e that is configured as the Internet router in the office.  It also has a VPN to one of the remote sites.

The internal network is 10.0.10.0 /24
The established VPN connects to 192.168.199.100

I need to create a VPN to connect to the 192.168.255.0 /24. The remote gateway for this is 66.69.69.168.

What makes this difficult for me is I have to NAT all traffic destined for the 192.168.255.0 network to 172.16.28.0 /24 network.

I was also told I need to create an ACL from 172.16.28.2 to the hosts 192.1638.255.100, 192.168.255.101, 192.168.255.102, 192.168.255.103

I have attached the current 'sh run' from the PIX.

Any help would be GREATLY appreciated!

**please note the names and network addresses have been changed to protect the innocent :)
: Saved - SANITIZED-
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password XxXxXxXxXx encrypted
passwd XxXxXxXxXxXx encrypted
hostname ABC
domain-name ABC.local
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 66.66.66.66 SVR1
name 10.0.20.0 ISP
name 192.168.255.0 COMP1
access-list inbound permit tcp any interface outside eq 3389 
access-list inbound permit tcp host SVR1 10.0.10.0 255.255.255.0 
access-list inbound permit tcp any interface outside eq 3390 
access-list inbound permit tcp any interface outside eq 3391 
access-list inside_outbound_nat0_acl permit ip 10.0.10.0 255.255.255.0 ISP 255.255.255.0 
access-list inside_outbound_nat0_acl permit ip 10.0.10.0 255.255.255.0 COMP1 255.255.255.0 
access-list outside_cryptomap_20 permit ip 10.0.10.0 255.255.255.0 ISP 255.255.255.0 
access-list inside_access_in remark implicit outbound rule
access-list inside_access_in permit ip any any 
access-list outside_cryptomap_40 permit ip 10.0.10.0 255.255.255.0 COMP1 255.255.255.0 
access-list acl_COMP1_nat permit ip 10.0.10.0 255.255.255.0 host 192.168.255.100 
access-list acl_COMP1_nat permit ip 10.0.10.0 255.255.255.0 host 192.168.255.101 
access-list acl_COMP1_nat permit ip 10.0.10.0 255.255.255.0 host 192.168.255.102 
access-list acl_COMP1_nat permit ip 10.0.10.0 255.255.255.0 host 192.168.255.103 
access-list acl_COMP1 permit ip host 172.16.28.2 128.0.0.0 128.0.0.0 
pager lines 24
logging on
logging trap debugging
logging host inside 10.0.10.2
mtu outside 1500
mtu inside 1500
ip address outside 66.67.68.69 255.255.255.192
ip address inside 10.0.10.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN 10.0.10.2 mask 255.255.255.0
pdm location 10.0.10.2 255.255.255.255 inside
pdm location 0.0.0.0 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
global (outside) 10 172.16.28.2
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 10 access-list acl_COMP1_nat 0 0
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 3391 10.0.10.2 3391 netmask 255.255.255.255 0 0 
static (inside,outside) tcp interface 3389 10.0.10.6 3389 netmask 255.255.255.255 0 0 
static (inside,outside) tcp interface 3390 10.0.10.11 3390 netmask 255.255.255.255 0 0 
access-group inbound in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 67.67.68.66 1
route outside SVR1 255.255.255.255 SVR1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+ 
aaa-server TACACS+ max-failed-attempts 3 
aaa-server TACACS+ deadtime 10 
aaa-server RADIUS protocol radius 
aaa-server RADIUS max-failed-attempts 3 
aaa-server RADIUS deadtime 10 
aaa-server LOCAL protocol local 
aaa authentication ssh console LOCAL
aaa authorization command LOCAL 
http server enable
http 10.0.10.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
sysopt connection permit-l2tp
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set pfs group2
crypto map outside_map 20 set peer 192.168.199.100
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 20 set security-association lifetime seconds 3600 kilobytes 100000
crypto map outside_map 40 ipsec-isakmp
crypto map outside_map 40 match address outside_cryptomap_40
crypto map outside_map 40 set peer 66.69.69.168
crypto map outside_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 192.168.199.100 netmask 255.255.255.255 no-xauth no-config-mode 
isakmp key ******** address 66.69.69.168 netmask 255.255.255.255 no-xauth no-config-mode 
isakmp identity address
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 28800
isakmp policy 40 authentication pre-share
isakmp policy 40 encryption 3des
isakmp policy 40 hash sha
isakmp policy 40 group 1
isakmp policy 40 lifetime 86400
telnet 0.0.0.0 255.255.255.255 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 60
console timeout 0
username JimmyCrackedCorn password XxXxXxXxXxXxXx encrypted privilege 15
username LittleMissMuffett password XxXxXxXxXxXxXx  encrypted privilege 15
terminal width 80
Cryptochecksum:123456789987654321123456789
: end

Open in new window

0
Comment
Question by:robertbranch
2 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 1500 total points
ID: 24276037
Here's an example of what I think you are describing. Some of it is already there...

\\-- define traffic that will be natted to 172.16.28.0
 access-list VPN_Natted permit ip 10.10.10.0 255.255.255.0 192.168.255.0 255.255.255.0

\\-- define traffic that will match the VPN encryption tunnel
 access-list crypto_nat permit ip 172.16.28.0 255.255.255.0 192.168.255.0 255.255.255.0

\\-- define a nat translation
global (outside) 10 172.16.28.1-172.16.28.254 netmask 255.255.255.0
nat (inside) 10 access-list VPN_Natted

\\-- create crypto map entry
crypto map outside_map 40 ipsec-isakmp
crypto map outside_map 40 match address crypto_nat
crypto map outside_map 40 set peer 66.69.69.168
crypto map outside_map 40 set transform-set ESP-3DES-SHA

>access-list outside_cryptomap_40 permit ip 10.0.10.0 255.255.255.0 COMP1 255.255.255.0
This is part of your problem. It needs to reference the natted IP and not the native 10.10.10.x

>I was also told I need to create an ACL from 172.16.28.2 to the hosts 192.1638.255.100, 192.168.255.101, 192.168.255.102, 192.168.255.103
I think this is a reference to allowing that traffic through any access-lists that you have applied. Your acl = permit ip any any, so that is not a problem


0
 

Author Comment

by:robertbranch
ID: 24298573
I resolved the issue you showed:

>access-list outside_cryptomap_40 permit ip 10.0.10.0 255.255.255.0 COMP1 255.255.255.0
This is part of your problem. It needs to reference the natted IP and not the native 10.10.10.x

for some odd reason, the syslog doesn't even show the tunnel being started now.
0

Featured Post

Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You deserve ‘straight talk’ from your cloud provider about your risk, your costs, security, uptime and the processes that are in place to protect your mission-critical applications.
In this article, WatchGuard's Director of Security Strategy and Research Teri Radichel, takes a look at insider threats, the risk they can pose to your organization, and the best ways to defend against them.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses
Course of the Month12 days, 7 hours left to enroll

578 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question