WSUS trouble on WS2003


For the past couple of days i noticed that my wsus is generating a lot of errors in the application log, I have very little (read "none at all")  experience with WSUS, so i need some step by step type help on this one.

these are the errors in the error log:

The DSS Authentication Web Service is not working.
The SimpleAuth Web Service is not working.
The Client Web Service is not working.
The Server Synchronization Web Service is not working.
The API Remoting Web Service is not working.
The Reporting Web Service is not working.
Self-update is not working.

Any help?
Who is Participating?
ictdoulosConnect With a Mentor Author Commented:
i am not sure what caused the problem, but it seems to have been resolved
It is AFAIK a known problem.
Open IIS console -> right click onto WSUS Administration -> Properties -> Select "Web sites" Tab and check if "Enable HTTP Keep-Alive" is selected. If no - select it, close all with OK and restart IIS.
ictdoulosAuthor Commented:
"Enable HTTP Keep-Alive" was enabled to begin with. does it matter that it has no ip address assigned?
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

Yes it is OK
Please ensure if you are really checking "Administration" and not "Default" site properties.
If you are, please un-select it, close configuration window and restart IIS and then please try to enable this option again. Maybe it'll help
BTW do yue use MCAfee? I have found an issue with McAfee and WSUS:
"This turned out to be a McAfee 8.5 issue. The update service usese the WsusService.exe which needed to be added to the user-defined policies in the McAfee ePO console for the server. Once I added this service as an exception problem resolved.
Other possible things which are causing your problem could be:
- logon time restrictions for the user IUSR_servername or something is wrong with that account
you should then first reset this account as described here
and check logon time restrictions
- check permissions under C:\Program Files\Update Services, Network service should have full control here

and check this link,
here is many other possible solutions.
Good luck!

ictdoulosAuthor Commented:
Under IIS i selected WEB-SITES > WSUS (right click) > Properties

The logon times seem fine, no restrictions there, but the Update services folder didn't have Network Service with full control, only read write, i have changed this and will see how it goes.

I do not have Mcafee on this system
ictdoulosAuthor Commented:
changing the access rights on the folder had no effect

When you say i have to Open IIS console -> right click onto WSUS Administration -> Properties -> etc

my iis console has WSUS under websites, but not WSUS administration, where can i find this?
Which version of WSUS are you using?
Because latest, AFAIK, has Administration as name for its website
ictdoulosAuthor Commented:
I am running wsus 3
version 3.1.6001.65

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.