• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 339
  • Last Modified:

Transport is runnnig for more than 8 hours ?

Transport  is running for more than 8 hours
where to look for the problem and  trouble shoot ?
0
sidharth100
Asked:
sidharth100
5 Solutions
 
Dag-EgilCommented:
Have you tried txc STMS, double click on the import queue, and then choose from the menu "Goto" -> "Import monitor" ?
0
 
mohonaCommented:
Cerainly a big problem. All background jobs have been assigned. Restarting the server will cure all memory related problems if there are any. BTW please mention your OS and SAP version.
0
 
Feroz AhmedSenior Network EngineerCommented:
Hi,
You can look for the job by making use of Transaction Code "SMX",or goto SE06 and see in OverView for More Information.
0
 
profjohan11Commented:
Hi,

1. In your transport log can you see if it stuck at one step, if so what is the error message?
2. Check of your transport jobs are running *rdd* i.e. RDDIMPDP follow sap note Note 71353 - Transports hang during background steps

Work form there.

Regards,

Johan
0
 
TwisteddkCommented:
First ensure that the transport isn't actually DOING anything, like for instance waiting for a conversion or import to take place in the database system, doing RFC, or is waiting for a resource.

If it's not, and it's actually "hanging", do the following:
a) Go to STMS, find your transport queue, refresh, and see if the transport is listed as active. If not, you may have a problem on your filesystem, access rights etc. Review the transport and import logs, and delete any temporary locking .LOB files
b) If the transport is listed as active, delete it from the import monitor, then go to each app server and kill any imports running (tp processes), then go to tables TBATG, TRJOB and TRBAT. Delete all entries. Then go to STMS, find your queue, and hit refresh.
c) Now you may reimport your request. Ensure that you use "import again" as an option. Also check "leave transport reuest in queue" and delete it manually after success, as you may need to try a couple of more things before this actually works
d) If this doesn't work, try step (b) again, and this time also reschedule RDDIMPDP, by running report RDDNEWPP in transaction SE38
e) If this doesn't work, You may have an underlying problem with a database connection. Try step b again, then run the import from the OS (CMD or shell)
f) If the fails, then start by doing a simple connection test "tp connect <SID> pf=<path_and_name_of_your_transport_domain_file>", if this fails, try "R3trans -x", resolve these problems before you continue.
g) If you're still having troubles, call a friend.

Note all of the above is conditional of you NOT running automatic imports, NOT running on a GxP system, NOT using transport express or other 3rd party transport tool, and that STMS is correctly configured, that You're NOT using a clustered, or otherwise HA environment that might conflict with the commands. Also, You need at least passing familiarity with the inner workings of STMS and the transport system to be able to interpret the log files, and this assumes that there are no problems with the buffer, that You're not in the middle of an upgrade, or are running a mixed OS environment, and that all mount points, filesystems and shares are available and correctly configured, as well as network and DB layer being in working order.

In any of those cases, there will be other reasons that might cause the hang, but from experience, about 50-70% of all stopped imports can be fixed by following the above described steps.

Good luck
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now