Cannot run batch files

Im having a problem with three machines (I suspect since the latest Micrososft patches last week).  The issue is the machines will not run any batch files as a specific user from the Windows XP Gui.  If you go to a cmd prompt you can run them fine, if you schedule them with the users credentials it works fine.

The exact error is "Windows cannot find 'c:\test.bat'. Make sure you typed the name correctly, and then try again.  To search for a file, click the start button, and then click Seach".

It doesnt matter where the batch file is.  If you right click on the batch file and choose edit you can view it, make amendments, save it, which suggests theres no permissions issue?

I've tried running the various registry scripts to reassociate batch files correctly, but they dont have any effect.
pmason08Asked:
Who is Participating?
 
fishadrCommented:
I posted:

The error is stating that it cannot find the file

the author posted:

one of their network drives wasnt mapping correctly,

If the mapping was not there the file would not be run from a cmd prompt!
0
 
Mal OsborneAlpha GeekCommented:
Tried renaming them as .CMD files?
0
 
pmason08Author Commented:
Yep, same thing.
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
fishadrCommented:
The error is stating that it cannot find the file, how are you running the scripts? If you are doing this via a link then try re-creating the link.
0
 
pmason08Author Commented:
No I was running them via double clicking the source file, not a shortcut.
0
 
pmason08Author Commented:
Right I've fixed this, and I cant really explain why.

I noticed on all the users who had the issue, one of their network drives wasnt mapping correctly, it appeared to be mapped in explorer, but if you double clicked on it you just got a empty folder.

Upon further investigation the users home drive permissions were incorrect (most puzzling as they had worked ok previously).  When I fixed this, rebooted the machines and the folder mapped ok, the batch files worked again.

If the batch files in question had been using this volume, or any network volume it might make more sense to me, but they were local scripts that did nothing via the network.

Still hopefully this might help if anyone else see's this issue.

Thanks for responses.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.