Can't register mswinsck.ocx on a new vista Home Premium SP1

I have a new vista computer that I cannot install my software on.  I am the developer and also wrote the install routine, everything else seems to run fine, but the program that uses mswinsck.ocx does not.

I tried to manually register it using the following steps:

Navigate to Start/All Programs/Accessories/Command Prompt
Right click on Command Prompt and select Run as Adminstrator
cd \windows\system32
regsvr32 c:\windows\system32\mswinsck.ocx

I get the following error:

The module "mswinsck.ocx" failed to load.

Make sure the binary is stored at the specific path or debut it to check for problems with the binary or dependent .DLL files.

The specified module could not be found.

However, typing "dir mswinsck.ocx" finds the file . . . . .

Thanks for your help.


lthamesAsked:
Who is Participating?
 
Mohamed OsamaConnect With a Mentor Senior IT ConsultantCommented:
Try installing the latest VB6 SP runpack redistributable, should sort it out, if this worked, you can add it as a step in your installer program.
http://www.microsoft.com/downloads/details.aspx?FamilyID=7B9BA261-7A9C-43E7-9117-F673077FFB3C&displaylang=en

0
 
davebuhlCommented:
The mswinsck.ocx file is not installed in the system32 directory as part of the standard Vista installation.  Did you do a seperate Visual Basic program install that brought in the files or manually place them in the System32 directory?

This link tells you which VB files are shipped with Vista and which are not
http://msdn.microsoft.com/en-us/vbrun/ms788708.aspx

I believe you have to install Visual Studio to get that file.  I could be wrong there.
0
 
lthamesAuthor Commented:
Yes, the file is there.  My install script put it there.

0
 
lthamesAuthor Commented:
I still don't know what the problem was . . . but it works now :)

Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.