Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 787
  • Last Modified:

Setting up a localhost testing server in Vista Home Premium

I'm trying to set up a local testing server for a site I'm developing in Dreamweaver, and I've never had much luck at it before.

Here's a link to a screenshot of my IIS Manager: http://dijitalrealm.com/images/IIS_Setup.png
The site folder is here: C:\Users\John|Documents\Graphic Design\Dreamweaver\dijitalrealm

Please tell me as thoroughly and explicitly as possible everything I have to do in IIS so that when I put "http://localhost" (or some extension thereof) into the url, it brings up the homepage of my site.

Thanks,
John
0
gabrielPennyback
Asked:
gabrielPennyback
  • 3
  • 3
1 Solution
 
wolfman007Commented:
To access your local web serve rusing localhost

1) make sure that localhost is listed properly in your hosts file.
2) disable IPv6 (it may be stopping you resolving localhost).

Also have a look at the following websites for some

ASP.NET Web Development Server Stops Working
http://blogs.msdn.com/webdevtools/archive/2009/03/13/asp-net-web-development-server-stops-working.aspx

Updating the HOSTS file in Windows Vista
http://www.mvps.org/winhelp2002/hostsvista.htm
0
 
gabrielPennybackAuthor Commented:
Hi wolfman, thanks for posting. This stuff is way beyond me at the moment, so I'm hoping that there is an easier way to prepare the OS for what I want to do. All I want to do is create a virtual directory or something like that so that when enter http://localhost  or http://localhost/something into the url, I see the index.html of my site that I'm dveloping in Dreamweaver.
Instead of fooling around with this other stuff, can I temporarily disable all the UAC controls?  Once I see it working I can reset the controls and learn how to do it the right way. But right now I just need some immediate gratification after all my failed attempts over the last 5 years or so. I've tried and each time I get discouraged after several hours of trying, and have always just used my remote site for testing, but I don't like that because sometimes you end up messing up your live site and I hate it when that happens. :-)
Thanks,
John
 
 
 
0
 
wolfman007Commented:
1) Open IIS Manager
2) Select your website
3) In the Actions Pane (on the right hand side) click "Basic Settings..."
4) In the Basic Settings window set the "Physical Path" to your site folder i.e.

C:\Users\John|Documents\Graphic Design\Dreamweaver\dijitalrealm

5) Click OK.
6) Open your browser and type in http://localhost and you should see your site.
0
Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

 
wolfman007Commented:
Here is a screenshot of the Basic Settings, just change the Physical Path.
Basic-Settings.jpg
0
 
gabrielPennybackAuthor Commented:
I'll check this out when i get home tonight, thanks.
0
 
gabrielPennybackAuthor Commented:
Here are my IIS settings. The top image shows the error. Must I have my website inside inetpub/www in order to test it?  Or must I add it as a virtual directory or whatever? I'm feeling incredibly incompetent at the moment! :-)


Thanks,
John

IIS-Settings.png
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now