Disconnected RDC sessions dropping after 1 minute on Windows 2008 x64 servers

We're having a issue with disconnected RDC sessions dropping after 1 minute on all 2008 x64 boxes. We have a 3rd party vendor that needs to run an app on our SQL Svr in a disconnected session. Apparently they're unable to run this as a service.

I've checked Group Policy, Local Policy and RDP Connection settings and all match both at system and user. RDP is set to override user setting with 'never' on all. We're running a mixed 2003/2008 environment with one 2003 DC and one 2008 DC. In testing we have the same issue with all our 2008 x64 boxes. This isn't an issue on any of our 2003 servers. It may also be worth noting we're running these servers on VMware ESX 3.5 hosts.

We've tried various versions of RDC and also connecting using IP rather than name. We're only trying this with selected Remote Desktop users and domain admin account right now.
BestofBanffAsked:
Who is Participating?
 
lnkevinConnect With a Mentor Commented:
So you could be able to find the root cause of this issue. The next step is figure out to open the rules in your ESX firewall to all RDP connections. The port to open in firewall is TCP port 3389. Check this guide:
http://pubs.vmware.com/vi35/server_config/wwhelp/wwhimpl/common/html/wwhelp.htm?context=server_config&file=sc_security_servcon.17.6.html

K
0
 
OriNetworksCommented:
Try going to Start->Administrative tools->Terminal Services Configuration and check the options for the server. YOu can speicify minutes to that session can stay active, when to reset disconnected sessions, etc.
0
 
BestofBanffAuthor Commented:
Yep..already checked there and tried a couple of alternatives. We had tried with override user settings ticked and tried both the 'never' expire and also specific minutes. It doesn't seem to matter what we set that to, the disconnected session will drop after 1 minute.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
lnkevinCommented:
Is there a firewall (software or hardware) between the client and server? If the server has Windows firewall enable, disable it. Otherwise, try the below set up:
On your 2008 server, go to your NIC's properties --> Configured (button) --> Advance (tab). Under Properties, look for Large send off load then set it to disable. Try it again.
http://www.petri.co.il/network-issues-with-windows-server-2008-rdp-on-dell-servers.htm

K
0
 
OriNetworksCommented:
Are you using users where this worked on server 2003?
0
 
OriNetworksCommented:
Are you using Citirix at all? Apparently it has its own policies... http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/844698f3-4a43-45ea-a575-f002119d337d
0
 
BestofBanffAuthor Commented:
Hi Kevin,

We don't run with Windows firewall and i'd already disabled large send offload. However, all our ESX 3.5 hosts run their standard VMware firewall. When this firewall is completely disabled the disconnected session remains as it should and doesn't drop after 1 minute. I'm not sure why this would cause a complete drop of disconnected sessions though.

OriNetworks, yes we are using the same users on the same network and they can still connect to 2003 without their disconnected sessions being dropped. We're not using Citrix in our environment.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.