• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 441
  • Last Modified:

Cannot install patch with Windows Remote Desktop

I am trying to install an application patch on a Windows 2003 R2 server using Remote Desktop and get the following error:  "The system administator has set policies to prevent this installation"

Any ideas appreciated.

Thanks in advance, Jay
0
jaygraves
Asked:
jaygraves
  • 6
  • 6
1 Solution
 
DanielWillmottCommented:
Try to RDP into the console of the system and run the update.
mstsc /v:<server> /console
(or mstsc /v:<server> /admin if you are on a Vista workstation)
If that doesn't work then there is a group policy you will have to track down.
0
 
jaygravesAuthor Commented:
That wasn't it.  Any idea what the policy could be and how to change it?
0
 
DanielWillmottCommented:
It could be just a registry entry. That would be the easiest place to start:
HKLM\Software\Policies\Microsoft\Windows\Installer
Check for a value for DisableMSI. If it's there, set it to 0.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
jaygravesAuthor Commented:
It was not there as a variable.  Any other thoughts appreciated.

Thanks, Jay
0
 
DanielWillmottCommented:
What application is the patch for?
0
 
jaygravesAuthor Commented:
It is for a specialized piece of database software from a small vendor.  Very odd since the install program worked - I just cannot patch it...
0
 
DanielWillmottCommented:
Perhaps if you create the value I mentioned above (a DWORD) and set it to 0. 0 means there are no restrictions for installing. A missing is supposed to imply 0 however.
0
 
jaygravesAuthor Commented:
I tried that ;)  I put DisableMSI as a DWORD = 0 in

HKEY_LOCAL_MACHINE/SOFTWARE/Policies/Microsoft/windows/Installer

0
 
OriNetworksCommented:
From a command prompt run gpresult to see what policies are being applied. You would then be able to examine these policies to see what setting might be restricting you.
0
 
DanielWillmottCommented:
I never asked - are you a local administrator?
0
 
DanielWillmottCommented:
Also this might be of help: http://support.microsoft.com/kb/290301
 
0
 
jaygravesAuthor Commented:
Yes, I am logged in as a local administrator.  The cleanup wizard didn't help.  Still looking around.  Thanks, Jay
0
 
jaygravesAuthor Commented:
Turns out the terminal server screen resolution was set to default 640 x 480 - you have to log in as admin and change it.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 6
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now