How to set FTP on IIS with router

Hi

I created a port 5050 in router to point to the local server at 192.168.1.50.
I open a dyndns to point to that machine. So, http://portforward.dyndns.org:5050 will point to it.

Now, I set up the default FTP on IIS 6 on windows 2003 server. I assigned the port to be 5050.

When I type ftp://portforward.dyndns.org:5050, it shows error:

Do you have permission to access the folder. (But, I grant all access in ftp)
200 Type set to A
500 Invalid port command
500 LPRT 6,16,0...command not understood

How should configure it correctly?
techquesAsked:
Who is Participating?
 
giltjrConnect With a Mentor Commented:
The 0.0.0.0:21 indicates that there is something up and running listening on tcp port 21.  Since this is the default port for ftp command/control connections I can only assume that this is the ftp server.

The 0.0.0.0 just means that the ftp server did not specify a specific IP address when it opened port 21, so it will listen and accept connections on any IP address that is configured on your server.

I would look at the event logs to see if there are any errors.  Obviously Windows does not believe you have changed the command/control port.
0
 
giltjrCommented:
LPRT is not a standard command FTP command (yet), it is part of RFC 1639 which is Experimental.    My guess is that MS IIS FTP server has not implemented it.

What FTP client are you using?
0
 
techquesAuthor Commented:
I just use a IE browser to open the ftp.
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
giltjrCommented:
Which version, 8?  
0
 
techquesAuthor Commented:
IE 6
0
 
giltjrCommented:
Um, it could be the ftp server may be configured not to allow active ftp (PORT command) and only allows passive ftp (PASV) command.  You may want to try changing your IE setting to use passive FTP.

This should be under the advanced tab of IE's options.
0
 
techquesAuthor Commented:
yes, IE was set passive FTP, but still not ok.

0
 
giltjrCommented:
Do you have any IE add-ons that could be intercepting the ftp stuff from IE and doing it?

You may want to try a free ftp client (like filezilla) and see if it works with your setup in passive and active mode. If filezilla works (espeically if it works in passive) then it is something weird with your IE and not with IIS.
0
 
techquesAuthor Commented:
I installed filezilla server on the remote machine, however, it cannot connect to server.

I set the ip to be 192.168.1.50 with port 5050.

FTP client filezilla also cannot connect to it.
0
 
giltjrCommented:
Have you actually configured IIS to listen on port 5050? On that server issue the command:

       netstat -an

and verify that IIS is listenting on port 5050.
0
 
techquesAuthor Commented:
You are right, when I type netstat -an, it does not has that 5050 port listening.
However, 1) I started the IIS FTP with 5050 port, 2) I set the router to accept TCP 5050 port and direct to the 192.168.1.50 machine.

Where did I set wrongly?
0
 
giltjrCommented:
Was something listening on port 21?

Make sure that the ftp server is setup to listen on port 5050.  Then stop and restart it.

You may still have some problems as most firewalls are design to "snoop" ftp traffic on port 21.  This way they can dynamically allow the data transfer connections to be established.  Using a non-standard port for the command/control connection could prevent the data connections from working once you get the command/control connection working.
0
 
techquesAuthor Commented:
for 192.168.1.50 machine, it has not listened port 21
but for 0.0.0.0, I saw it has 0.0.0.0:21

yes, ftp server is set to port 5050 and i stop and restart it.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.