Problem accessing web server on 443

I have a internal web server that hosts an application that is availible through IE by going to http://192.168.1.XXX/WEBSITEAPP. I installed an SSL certificate on the server to grant access from the outside on port 443. I have a domain registered as well. I have opened 443 in the firewall and NAT to the private address. Here is the problem. The website need to have the /WEBSITEAPP after the IP and when traffic is sent through the firewall it just sends it to 192.168.1.XXX. I went it to IIS and did the redirected to 192.168.1.XXX/WEBSITEAPP and it work internally but not when access it takes the URL and changes it to the 192 address and that wont work from the outside. I can telnet to port 443 from telnet to DNS name so I thinks its just a setting I missed in IIS. Thoughts??
osxlaAsked:
Who is Participating?
 
cj_1969Connect With a Mentor Commented:
How did you do the redirect?
If you did it via the IP or machine name then this is not going to work for outside clients as they do not know of the internal IP or machine name.
Try using a relative reference for the redirect ... i.e.  /websiteapp or use the FQDn that is used from the outside i.e. http://fqdn/websiteapp
If youuse the second approach then you should create the domain internally in your DNS and over ride the externa lP with the internal IP
0
 
osxlaAuthor Commented:
Thanks, Putting in the FQDN did the trick in IIS redirect box.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.